1

I seem to have a variant of a very common problem. Yesterday, I booted into ubuntu for the first time in a few weeks. I ran updates for a while - everything worked fine and I suspended my system and went to bed. Today evening, I tried to suspend my system and it would immediately wake up again. I tried to reboot, and after that I was unable to login via the gui. This was a problem I had faced before, and my first guess was that I was having issues with my nvidia drivers (manually installed drivers from nvidia for work). I switched to tty and installed an updated driver. I switched back to the gui, and now I was able to login, but I was faced with a blank desktop. I switched back to tty and started ccsm, which is the usual solution to having no launcher, icons, etc. However, (a) ccsm was only half "on screen" for me, and I couldn't move the window fully on screen because I still hadn't enabled that feature in ccsm. Furthermore, any options that I could see in the ccsm window (unity, opengl, etc.) had no effect when clicked. I tried to roll back to my previous nvidia driver, but that didn't change anything. I also tried to purge and reinstall xserver, but that seems to have had negative effects. Previously, I had a white cursor and could right click on my desktop and view the right click menu (I could even access the system settings that way). After the xserver reinstall, my server is now black, and I can't right click. Furthermore, my desktop has some odd, random (changes every reboot) fragments mixed in. I've also tried to login to the guest account both before and after the xserver reinstall. Before the reinstall, everything worked fine in the gui. After the reinstall, this is what I see: enter image description here

I apologize for the wall of text - just wanted to make sure I write down all the (possibly) relevant details. In summary:

  1. Had login issues due to nvidia drivers
  2. ccsm checkboxes did nothing
  3. purged and reinstalled xserver
  4. ccsm still does nothing but now I have a bugged desktop, a black cursor, and cant rightclick on my desktop
  5. guest account worked fine before the reinstall, but now has a weird look

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.