1

I see this post, but the setting mentioned there doesn't seem to exist in Ubuntu 16.04.1.

Did it get moved? Do I need to create it? Something else? Note that we wouldn't be having this conversation except our senior guys who work on Mac can't connect to help out our other guys on Ubuntu.

  • I've found it. You need to start with org, not Gnome. – user447607 Sep 26 '16 at 18:40
0

Most articles mention disabling "require encryption" but you also need to change the "security mode", otherwise it never connects. There are two changes you must make in dconf-editor.

http://www.japanmobiletech.com/2015/02/screen-sharing-between-mac-os-x-1010.html

While the article is far more detailed, below is an overview, go to linked article for a more detailed explanation and other things you might want to do. Even though it is for an older version of Ubuntu some of it may still be useful and most of the settings for this specific issue are the same. This was tested on 16.04.

1) Install dconf tools

sudo apt-get install dconf-tools

2) run dconf-editor

3) edit org > gnome > desktop > remote-access disable require-encryption (do not press set-default)

4) Change authentication-method from 'none' to 'vnc' (do not press set default)

5) exit dconf editor

6) In terminal type

vino-preferences

and select "Require the user to enter this password:" then enter a password.

Go to your Mac and connect via the Connect in the finder vnc://yourhostname.local it should work rather than show a spinner.

  • In the link you posted it's about Ubuntu 14.04. but the OP asked for 16.04.1 and also mentioned that his linked post didn't help him which is using the same method as you suggested – derHugo Jul 14 '17 at 7:12
  • Really a downvote? Did you try it? It was behaving exactly the way he described until I set the vnc security mode, just setting the other setting did not fix it. Just because it is an older version does not mean it is is incorrect. The answer he linked to did not solve the problem completely and I am using 16.0.4. 1 and both options are there so the 14.0.4 info is still correct. – possen Jul 14 '17 at 7:25
  • Hi I'm saying your "Answer" does not provide anything new since OP already posted a link to a manual that uses exactly the same method as yours does. Downvote is not from me though but consider rather adding the information/step by step to your answer than just posting a Link here – derHugo Jul 14 '17 at 10:52
  • I respect what you are saying, but I believe that is incorrect. This is an unanswered question until I answered it, the linked post in the question is incomplete because it does not mention setting the VNC security mode, it will not work unless you do this, and I linked to the article because it is far more detailed than what I would be able to do in a reasonable amount of time. I will update my answer to give an overview, if that works for you. – possen Jul 14 '17 at 19:38
  • Hopefully the changes I made above resolves the issue. – possen Jul 14 '17 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.