5

I just installed Ubuntu 16.0.4 and no Wifi connections are showing up in my networks. So I tried:

sudo apt-get update
sudo apt-get install bcmwl-kernel-source

And this didn't change anything even though it installed successfully. Then I tried updating the system, which also didn't help.

I then tried the troubleshooting guide, and the first step tells me to write

nm-tool 

in the terminal. This command isn't recognized.

So I try lshw -C network to see if my device is recognized at all. It's not -- only the ethernet I'm using. So then I try

sudo lsusb -v

And it shows that apparently my USB device is being detected:

Bus 001 Device 005: ID 13b1:003e Linksys AE6000 802.11a/b/g/n/ac Wireless Adapter [MediaTek MT7610U]

But, the docs don't tell me what to do beyond finding out what type of device I have. What steps can I take to activate this wireless/download the drivers I need? Thanks.

EDIT:

Output of dkms status :

mt7610u, 0.2, 4.4.0-38-generic, x86_64: installed

Output of usb-devices | awk '/003e/' RS= :

T:  Bus=01 Lev=02 Prnt=02 Port=05 Cnt=03 Dev#=  5 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=13b1 ProdID=003e Rev=01.00
S:  Manufacturer=Cisco
S:  Product=Linksys AE6000
S:  SerialNumber=0009
C:  #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 8 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
  • What is the Ubuntu version? And what was the point of installing Broadcom drivers? – Pilot6 Sep 26 '16 at 18:12
  • @Pilot6 I don't know, I'm a newb and I'm just pasting things off the interwebs to try to get my internet working. The version is 16.0.4 – David J. Sep 26 '16 at 18:16
  • Did you try rebooting? – You'reAGitForNotUsingGit Sep 26 '16 at 18:18
  • @AndroidDev What is the point of rebooting without drivers? – Pilot6 Sep 26 '16 at 18:21
  • 1
    You need to run the full command usb-devices | awk '/003e/' RS=, not only a part of it. – Pilot6 Sep 26 '16 at 18:50
5

Disable Secure Boot in BIOS and run in terminal

sudo apt purge bcmwl-kernel-source
sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt update
sudo apt install mt7610u-dkms

Reboot.

This will remove Broadcom drivers and install Mediatek ones.

| improve this answer | |
  • Thanks for the suggestion, but I went through these steps and it still doesn't work. No wireless connections detected. – David J. Sep 26 '16 at 18:35
  • Make sure it isn't disabled by hardware switch. – user589808 Sep 26 '16 at 18:39
  • @DavidJ. Did the driver install OK? It supports this adapter. – Pilot6 Sep 26 '16 at 18:40
  • @Pilot6 Yes, installation was successful – David J. Sep 26 '16 at 18:41
  • @Pilot6 Disabled secure boot. Now using my usb wifi! Thanks for your excellent help. – David J. Sep 26 '16 at 19:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.