0

Starting Nmap 7.01 at 2016-09-26 18:54 CEST Nmap scan report for mypage.com (IP-ADRESS)

I'm a Ubuntu beginner. I've set up a dyndns service to redirect the connection for my domain. I've turned off the firewall.

When I type

sudo nmap IP-ADRESS

it shows:

Host is up (0.93s latency). 

rDNS record for IP-ADRESS: IP-ADRESS.cable.dynamic.surfer.at 

Not shown: 994 filtered ports 

PORT     STATE  SERVICE 

20/tcp   closed ftp-data 

21/tcp   closed ftp 

23/tcp   open   telnet 

80/tcp   closed http 

443/tcp  closed https 

8089/tcp closed unknown 

Why is only the 23 port open? What is closing the other ports?

I use a router (for the dyndns service) and set the 23,80,443 ports free.

0

That output looks like you've run nmap against a standard domestic router, so I'm assuming you have a computer on a 192.168.x.x network behind a NAT router.

When you say you've turned off the firewall, do you mean you've turned off your computer's UFW firewall? In which case, you'll still need to add port forwarding rules to your router to direct incoming traffic to your computer. There are websites which provide port forwarding guides for various routers. You need to know which TCP or UDP ports you'll be using.

If you are running a webserver from within a VM, you need to ensure traffic can go from your 192.168.x.x network to the VM. By default, VirtualBox puts VMs in a 10.x.x.x network, with your host acting as a NAT router. From the VirtualBox application, edit the network settings for the VM, and under Network Adapter 1, switch it from NAT to Bridged Adapter. This will give your VM an IP address on your 192.168.x.x network, making it addressable from your router.

Then on your router, forward TCP port 80 to the IP address of your VM (and not your VM host machine).

5
  • I use Ubuntu as host and ubuntu as guest on the VM Virtualbox. On the host-machine there was no service listen on the ports, so it was closed. I've installed apache server on the host and i've got the connection from my domaine! – Dusko P Sep 27 '16 at 8:22
  • but now: how i can keep the port open without a apache server installed on the host-machine and how i can redirect the connections to my guest-vm? – Dusko P Sep 27 '16 at 8:25
  • is the redirection with the firewall pfSense a solution? – Dusko P Sep 27 '16 at 8:26
  • i've solve it over the virtualbox setup of the network-modus called bridged. through it the guest-vm gets own ipadress. – Dusko P Sep 28 '16 at 12:51
  • Glad you fixed it. I had update my answer to suggest switching the VM network adapter to Bridged; was that useful to you? – Hadog Sep 28 '16 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.