1

I am trying to connect thru my Ethernet port on my Dell desktop computer. I just installed a switch to connect my ooma phone and computer on the same connection in my room. When I boot up the computer I see the port connect, but once its booting to Ubuntu the port turns off. My wireless does work fine and I dual boot this same computer with Windows 10 and works just fine with the switch. Once logged in I run the following command: sudo ethtool -s eth0 speed 100 duplex full autoneg off The port turns on and I can connect, but at a very slow speed. I have FIOS 100/100MBPS internet speed. I tried changing the 100 to 1000, but received an error of not supported. Here's some info to understand my problem:

-Vostro-270s:~$ dmesg | grep "eth0"
[    0.738498] r8169 0000:04:00.0 eth0: RTL8168evl/8111evl at 0xffffc90000c6a000, a4:1f:72:88:bc:89, XID 0c900880 IRQ 28
[    0.738500] r8169 0000:04:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[   26.987264] r8169 0000:04:00.0 eth0: link down
[   26.987268] r8169 0000:04:00.0 eth0: link down
[   26.987321] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   27.094342] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[  525.696956] r8169 0000:04:00.0 eth0: link down
[  525.697005] r8169 0000:04:00.0 eth0: link down
[  525.697044] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[  852.138799] r8169 0000:04:00.0 eth0: RTL8168evl/8111evl at 0xffffc90000c6a000, a4:1f:72:88:bc:89, XID 0c900880 IRQ 28
[  852.138802] r8169 0000:04:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[  852.265177] r8169 0000:04:00.0 eth0: link down
[  873.162612] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready


Vostro-270s:~$ ethtool eth0
Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Speed: 10Mb/s
    Duplex: Half
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
    Current message level: 0x00000033 (51)
                   drv probe ifdown ifup
    Link detected: no

Vostro-270s:~$ sudo lshw -class network
[sudo] password:
  *-network               
       description: Wireless interface
       product: AR9485 Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 01
       serial: 70:18:8b:af:0b:c3
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=4.4.0-38-generic firmware=N/A ip=192.168.1.170 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:18 memory:f7800000-f787ffff memory:f7880000-f788ffff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 07
       serial: a4:1f:72:88:bc:89
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:28 ioport:d000(size=256) memory:ea104000-ea104fff memory:ea100000-ea103fff

Let me know if any more information is needed.

  • What driver is the ethernet port using? Easiest just to look in Connection Information in the network menu. Cheers, Al – heynnema Sep 26 '16 at 0:54
  • I am using r8169. When I get home I can send a screen shot of this information. – carivera098 Sep 26 '16 at 14:01
0

The r8169 ethernet driver is buggy. Using Synaptic, install r8168-dkms. Turn off secure boot in your BIOS.

Start Synaptic, click the RELOAD icon, then the SEARCH icon, type in r8168-dkms, mark it for installation, then click the APPLY icon. Quit Synaptic. Reboot the computer. Then disable secure boot in the BIOS.

That should solve the problem. Cheers, Al

  • Thanks for the info and I did what you said and fix most of my problems. The only thing now is my speed. I have FIOS 100/100 down/up and all I am getting is 7Mbps. I have tried changing the port speed with – carivera098 Sep 27 '16 at 0:29
  • sudo ethtool -s eth0 speed 1000 duplex full autoneg on – carivera098 Sep 27 '16 at 0:30
  • But did not work. Please let me know how I can get the max speed. By the way, I dual boot to Windows 10 and get 95Mbps. – carivera098 Sep 27 '16 at 0:32
  • What happens if you connect the computer directly to your FIOS adapter/modem? Eliminate the switch/etc. Is it a gigabyte switch? Please remember to vote/accept my answer as the solution to your ethernet problem. Cheers, Al – heynnema Sep 27 '16 at 0:33
  • Eliminating the switch did the trick. Thanks you for all your help. Now time to buy a new switch. Thanks – carivera098 Sep 27 '16 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.