1

I am unable to enable Palm Detection on my Ubuntu Lenovo ThinkPad Lenovo Laptop with a Synaptics touchpad. I have tried the following commands:

  1. xinput list
  2. xinput list-props "{id}"
  3. xinput set-prop "{id}" "Synaptics Palm Dimensions" 5, 5
  4. xinput set-prop {id} "Synaptics Palm Detection" 1

I tested my palm against the touchpad and the cursor still moved. I also tried this 'synclient PalmDetect=1 PalmMinWidth=xx PalmMinZ=yy' but this also didn't work.

What am I missing? Are the commands incorrect and what would be the right values? I am setting these values on a terminal and then testing against my touchpad. That should work right? Or do I have to restart my system each time for it to take effect? I have set these values on startup also

1

For anyone looking - the workaround I found was setting AreaRightEdge to 80% of the total. This means that motions, clicks, etc initiated on the right most 20% will be ignored but still leaves the entire touchpad usable as long as a movement is initiated elsewhere (i.e. the middle).

Run this to list out your settings:

synclient -l

For me I got

LeftEdge = 1574
RightEdge = 5368
...

I set AreaRightEdge using the following command

synclient AreaRightEdge=4500

You can use evtest to get a realtime position of your finger to determine the right placement. This solved all my palm detection and phantom movement issues.

0

I think you are misunderstanding what Palm Detection is. Palm detection disables erroneous touches made by, say, the palm, while typing. If you type continuously, and touch the touchpad while typing, the cursor should not move.

You can test this by holding down a key on your keyboard and attempting to move the cursor with the trackpad. If the cursor moves, then there is an issue. If it doesn't then Palm Detection is working.

The touchpad can't detect your palm, specifically.

0

If you're trying to stop extraneous cursor movements or clicks from the trackpad whilst you're typing, you should install touchpad-indicator. It has a good selection of preferences to customize its operation.

Using Synaptic, click the RELOAD icon, then the SEARCH icon, enter touchpad-indicator, put a X in front of the only result found to mark it for installation, click the APPLY button.

Once installed, start it from the Unity dash. Set the preferences to autostart. Set the other preferences to your taste. Cheers, Al

0

I know this is an old question, and my solution would have probably not worked well in 2016, but I fixed this issue by switching to Wayland.

I use the Lenovo ThinkPad X1 Yoga 3rd Gen, and the palm detection features when using X.org didn't seem to do anything. I knew that the hardware was capable of doing true Apple trackpad style palm detection, because, on Windows, I could rub my palm vigorously across the touchpad and the mouse pointer wouldn't budge.

To switch to Wayland, log out of your user account, and there should be an option on the login page that shows a dropdown with "Wayland" as an option. If not, see this answer for more details.

Voila! I can now smear my whole palm on the touchpad again and not worry about accidental taps and mouse movement.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.