0

I have a MSI PX60 6QE laptop with Windows 10 pre-installed.

I want to install Ubuntu having a dual boot. I have reserved space for it:

Disk space

Disco 0 is my ssd, and disco 1 the hd.

However, when installing it, the laptop freezes when Ubuntu screen is loading. I have tried with some Ubuntu versions such as 16.04, 15.10 and 14.04. None works.

I have played a bit with the bios options, secure boot, fast boot, uefi/legacy bios... But it seems I don't get the correct configuration.

Also I have tried with some kernel parameters, such as the nomodeset or the cstates.

How can I solve it, and install Ubuntu correctly?

6
  • While hardware may be UEFI, is Windows installed in UEFI boot mode? It does not look like a typical UEFI install. If drives are gpt partitioned then UEFI, but if MBR(msdos) then BIOS. And you then need to install Ubuntu in the same boot mode. Post this from live installer: sudo parted -l MSI PX60 2qd 034us Haswell & Optimus libata.force=noncq for SSD hangup ubuntuforums.org/showthread.php?t=2296878
    – oldfred
    Commented Sep 25, 2016 at 16:15
  • 2
    I see you have a Skylake machine. I also struggled to get Ubuntu on my Dell Skylake machine. What worked for me was Ubuntu 14.0.4.5 LTS(I chose the GNOME version, tired of Unity). I also added the nouveau.modeset=0 in the GRUB options, and now I happily dual boot them together. You will need to poke around various boot options before it starts booting. I can lead you to this. Commented Sep 25, 2016 at 16:16
  • Worked @TonyLancer suggestion! I managed to install Ubuntu 14.04.5 LTS. I have had to add the nomodeset option too, but in the screen opened with e key, and not with c as your link provided. Commented Sep 25, 2016 at 17:19
  • @SantiGil Does everything work fine? If so, allow me to post my comment as answer so you can accept it. Commented Sep 25, 2016 at 17:49
  • @TonyLancer yes you can post and I accept. I have now the problem that I can't decide which O.S. to boot, I enter always in Windows (Grub doesn't appear). I enter in Ubunty by pressing F11 and then boot Ubuntu. But I will investigate, the rest is working! (Message sent from Ubuntu ;) ) Commented Sep 25, 2016 at 18:08

1 Answer 1

2

I see you have a Skylake machine. I also struggled to get Ubuntu on my Dell Skylake machine. What worked for me was Ubuntu 14.0.4.5 LTS(I chose the GNOME version, tired of Unity). I also added the nouveau.modeset=0 in the GRUB options, and now I happily dual boot them together.

You will need to change the boot options after that. You need to find out what button gets you to the BIOS(on my Dell it is F12). Go to the boot settings, and swap the boot priority(make Ubuntu first, followed by Windows).

You should be good to go after this! :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .