0

I upgraded and when I checked it had issues booting, so I rebooted, and I got the menu to select Ubuntu or memory checks etc and chose Ubuntu. it first booted to login for 14.04 and said last login July 2016??? So I rebooted and again got to login prompt that said 16.04.1 last loging todays date. so I was happier. But no desktop. I try and do apt-get update to finish update but got errors because my network was not up. SO now I guess I need help getting an ip address and internet. I tried to restart network and manager but errors. ifconfig reports no IP address, which should be 192.168.0.3. I tried adding ip but get error saying gatway not found. Not sure how to get the desktop to load or if it was installed. I thought I should get network working first, then finish or check updates. But I need help with networking please. Any help appreciated.

Update: I now have an IP address!! on eth0 and I was able to ssh in remotely. Still have errors when I run apt-get update. I see:

    norman@merlin:~$ sudo apt-get update
[sudo] password for norman: 
Err http://us.archive.ubuntu.com xenial InRelease

Err http://us.archive.ubuntu.com xenial-updates InRelease

Err http://us.archive.ubuntu.com xenial-backports InRelease

Err http://security.ubuntu.com xenial-security InRelease

Err http://archive.canonical.com xenial InRelease

Err http://us.archive.ubuntu.com xenial Release.gpg
  Temporary failure resolving 'us.archive.ubuntu.com'
Err http://us.archive.ubuntu.com xenial-updates Release.gpg
  Temporary failure resolving 'us.archive.ubuntu.com'
Err http://security.ubuntu.com xenial-security Release.gpg
  Temporary failure resolving 'security.ubuntu.com'
Err http://archive.canonical.com xenial Release.gpg
  Temporary failure resolving 'archive.canonical.com'
Err http://us.archive.ubuntu.com xenial-backports Release.gpg
  Temporary failure resolving 'us.archive.ubuntu.com'
Reading package lists... Done
W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial/InRelease  

W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial-updates/InRelease  

W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/xenial-backports/InRelease  

Here is ifconfig results:

norman@merlin:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:16:17:2d:3a:ce  
          inet addr:192.168.0.3  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::216:17ff:fe2d:3ace/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:53 errors:0 dropped:0 overruns:0 frame:0
          TX packets:94 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7389 (7.3 KB)  TX bytes:15389 (15.3 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1332 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1332 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:99664 (99.6 KB)  TX bytes:99664 (99.6 KB)
  • Could you please run the network diagnostics and edit your question to include a link to the result? Thanks. – David Foerster Oct 1 '16 at 2:19
  • @DavidFoerster this seems for wireless. I have always and am just trying to fix a system whee I am using wired ethernet connection. No wireless. it just broke due to upgrade failure and I want to fix it and not connect another way. Makes sense? How do I un-foobar what the upgrade did. My files are there but its like the upgrade broke and i dont have all the required system files. Is there a way to install a 16.04.1 cd and repair or something? – Norman Bird Oct 1 '16 at 15:36
  • The diagnostics provide excellent information about wired network connections too. I suspect that this is a simple device driver or networking configuration issue. If you have a new or follow-up question please open a new question. The comment section is not suitable or meant for new questions or extended discussion. Thanks. – David Foerster Oct 1 '16 at 16:20
  • just for the record I have decided to just reinstall from scratch and consider this a botched upgrade. Upgrades to me should at least reload a working system. thanks anyway guys. No need for more answers. Not deleting. – Norman Bird Oct 1 '16 at 17:40
  • Do you still have this issue? – Elder Geek Oct 2 '16 at 16:36
1

I wonder if you have more than one screen for your desktop? I do and seem to face these sorts of issues every time I install a new release...

I faced similar issues, but not the network ones... basically Unity had to be started after a basic X restart to give me a usable system (otherwise I only had a wallpaper and a mouse cursor!).

My recipe to fix this was to CTRLaltf1 to give me a TTY screen with command line where I can logon. Then a simple startx unity will get X started and gives me a basic, but unsatisfactory system. So <CTRL> C from the X terminal to leave that and you should fall back to the TTY terminal.

Follow that with sudo service lightdm start and I was good to go. Next use CTRLaltf7 to return from tty screen to my Unity session.

Liberal use of the "Suspend" function might stop this being too much of a pain, because it is far from ideal, more a workaround than a solution. Also, and I cannot explain this, it will not always work for me - seems to work about 3 times out of four. Another shortcoming is that with this desktop I'm unable to drag anything onto it, nor does Rubbish bin or any mounted drive show up there.

I was going to make my own post asking how I can get boot to incorporate the starting of unity and subsequent service start, but this was so close to my symptoms I thought I would share - hopefully it works for you?

Even more hopefully someone with a deeper understanding of X and lightdm screenmanager can identify a way forward for a proper solution which might make its way into updates soon!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.