1

I have upgraded from xubuntu 14.04 64 bit to xubuntu 16.04 bit and now the system does not boot normally. I have to go through recovery mode and choose either clean or repair but then I have limited graphic and no external monitor.
It is a laptop ACER - Aspire E5-571 Intel Core i5-5200U 4Gb ram - Intel Corporation HD Graphics 5500 (rev 09).
There is a efi dual boot with windows.

I have tried the following commands.

sudo dpkg configure
sudo apt install f
sudo apt install systemd

But that did not change anything.

I post bellow an extract of the log boot that should show the section before and after recovery

 systemd[1]: Started Getty on tty1.
 systemd[1]: Reached target Login Prompts.
 systemd[1]: Starting Set console scheme...
 systemd[1]: Started Set console scheme.
 systemd[1]: Started LSB: disk temperature monitoring daemon.
 gnome-keyring-daemon[1954]: couldn't access
control socket: /run/user/1000/keyring/control: File o directory non esistente
 NetworkManager[1341]: <info>  [1474728198.2489] WiFi hardware radio set disabled
 NetworkManager[1341]: <info>  [1474728198.2489] WWAN hardware radio set disabled
 systemd[1]: teamviewerd.service: PID file
/var/run/teamviewerd.pid not readable (yet?) after start: No such file or directory
 systemd[1]: Started TeamViewer remote control daemon.
 systemd[1]: Started Recovery mode menu.
 systemd[1574]: Time has been changed
 ntpdate[1737]: step time server 91.189.89.198 offset 2.048170 sec
 systemd[1]: Time has been changed
 systemd[1]: snapd.refresh.timer: Adding 5h
17min 5.685294s random time.
 systemd[1]: snapd.refresh.timer: Adding 3h 7min
31.108270s random time.
 systemd[1]: apt-daily.timer: Adding 3h 2min
49.775354s random time.
 gnome-keyring-daemon[1954]: The SSH agent was
already initialized
 gnome-keyring-daemon[1954]: The Secret Service
was already initialized
 gnome-keyring-daemon[1954]: The PKCS#11
component was already initialized
 org.a11y.Bus[1919]: ** (process:2076): WARNING
**: Failed to register client:
GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name
org.gnome.SessionManager was not provided by any .service files
 org.a11y.Bus[1919]: Activating service
name='org.a11y.atspi.Registry'
 org.a11y.Bus[1919]: Successfully activated
service 'org.a11y.atspi.Registry'
 org.a11y.atspi.Registry[2081]: SpiRegistry
daemon is running with well-known name - org.a11y.atspi.Registry
 systemd[1]: Started LSB: start Samba daemons
for the AD DC.
 nmbd[1882]:  * Starting NetBIOS name server nmbd
 nmbd[1882]:    ...done.
 systemd[1]: Started LSB: start Samba NetBIOS
nameserver (nmbd).
 systemd[1]: Starting LSB: start Samba SMB/CIFS
daemon (smbd)...
 smbd[2092]:  * Starting SMB/CIFS daemon smbd
 smbd[2092]:    ...done.
 systemd[1]: Started LSB: start Samba SMB/CIFS
daemon (smbd).
 systemd[1]: Reached target Multi-User System.
 systemd[1]: Starting Notify bootloader that
boot was successful...
 systemd[1]: Reached target Graphical
Interface.= vuol dier login screen

Thanks!

0

Actually I realized that with the kernel 3.19.0-xx-generic upstart everything works fine (except for a very slow log out). At boot, you should have for 1 or 2 seconds a screen with the list of kernel you can use, to stop it, enough to press for example the down button. If you do not have the kernel list, I think there is a key (maybe F5) or a combination of keys.

The explanation, if I well understood, is that there are now 2 boot tecnologies, the old "upstart", the new "systemd", the kernels following 3.19 (4.4...) use systemd only, the 3.19 and before make you choose. In the upgrade from 14.04 to 16.04 program there is an error and you can boot only with 3.19... upstart. If you absolutely need/want to use the latest kernel, for the moment, I found around as solution only reinstall : (

0

You don't need to change your kernel version to return to upstart. You can use upstart always, as described in the Ubuntu wiki:

  1. install the upstart-sysv package: sudo apt install upstart-sysv

  2. run sudo update-initramfs -u

You will then boot by default with upstart and you will get an advanced boot option to boot with systemd i you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.