0

I have a 16GB USB for ISO image, a 64GB USB for installation of Ubuntu 16.04 on window 8.1 as an external drive. My internal harddisk has C: and D:

After enter 'Try Ubuntu' then click 'Install Ubuntu'. My boot priority set to external drive then internal drive. Boot secure and fast start up disable.

My 64GB partition as follows:

  • (6GB primary, ext4, swap)
  • (500M logical EFI)
  • (remaining GB logical, ext4, mount as /)

Boot loader set as the EFI in my 64GB USB drive

Tried few time to install Ubuntu, it stopped at:

grub-efi-amd64-signed package failed to install into/target/

Even I tried to repair the boot loader and followed most of the post but none can fix it.

0

I followed this guide UEFI and I finally got the same error to go away.

If you read 1. Boot mode matching -- "If you're dual-booting with another OS, the two OSes' boot modes should match. Most computers that ship with Windows 8 and later use UEFI to boot that OS, so this configuration dictates use of UEFI mode when installing and booting Ubuntu."

So it seems like you need to download GRUB or get rid of window 8.1. I am not familiar with how to install GRUB, but this link will be useful GRUB MANUAL.

I hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.