11

I'm running Lubuntu 14.04. I'm a little concerned about the following Mono process that runs at startup, though it seems to be inactive. The command used to start this process was :

/usr/bin/mono /usr/lib/mono/4.5/xsp4.exe --port 8084 --address 0.0.0.0 --appconfigdir /etc/xsp4 --nonstop

and started by www-data.

I have never seen a Mono process run at startup before, and I can't think of a reason for it to be running. There also seems to be nothing in my startup services. Here is the output of initctl list :

http://pastebin.com/ttqKGPUH

What could this process be, and is it something to worry about ?

  • Is it really vanilla Lubuntu 14.04? Your pastebin content seems to indicate that there's a lot of other stuff present? – DK Bose Sep 25 '16 at 17:29
  • I never said it was "vanilla". Only that I could think of no application that would require Mono to be running at startup . Hence I was concerned there could be something malicious. Also, I have installed several applications such as gnome-disks, and Okular, which may be the reason why there are entries related to those in the initctl output. Also, whoever downvoted the question, please tell me why you think the question was not appropriate. – NILobachevsky Sep 26 '16 at 4:57
7

The mono-xsp4 is shipped with a SysV init script at /etc/init.d/mono-xsp4.

To disable the automatic startup run the following command.

update-rc.d mono-xsp4 disable 
| improve this answer | |
9

As pointed out in the answer by Thomas, it's easy enough to stop or disable this server, but you may want to consider whether you actually might want it running before you do. I found this question while researching this exact same concern on my own Kubuntu 18.04 LTS machine, and this helped me dig deeper into what it actually was. Turns out it's used to serve monodoc-http, as I was able to determine by exploring the content of files found in /etc/xsp4 and /usr/share/monodoc/web.

If you installed MonoDevelop or MonoDoc or anything related to developing code in Mono, then that's where it came from. If you did that on purpose because you're learning or coding in Mono, then you may actually want that service running. If you have no use for MonoDoc services, you can easily disable them on flavors of Ubuntu (and other distros which use systemd) using systemctl.

  • sudo systemctl stop mono-xsp4.service will stop the service
    (but won't disable it, so it will run again after next reboot).
  • sudo systemctl disable mono-xsp4.service will disable the service
    (but will not stop it if it is running currently).

You'll need to run both commands if you wish to actually stop the service now, and disable the service so that it's not running after the next reboot. If you know for certain that you have no use at all for MonoDoc and related services, you can also search for them in your package manager and uninstall them entirely.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.