17

These are the problems shown on the terminal:

W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/andale32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/arial32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

Similarly many other files related to ttf-mscorefonts-installer.

marked as duplicate by muru, Fabby, Zanna, TheWanderer, Kevin Bowen Feb 4 '17 at 18:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

30

The one that SOLVED the problem was a manual install (@rag2):

wget http://ftp.de.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.6_all.deb
sudo dpkg -i ttf-mscorefonts-installer_3.6_all.deb

Details: https://gist.github.com/melvincabatuan/26f3ac4ace4be3a8b48d85a1b3250982

Unfortunately, the following answer didn't work for me (in Ubuntu 16.04).

sudo rm -rf /var/lib/update-notifier/package-data-downloads/partial/*
sudo apt-get --purge --reinstall install ttf-mscorefonts-installer

Result:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  ubuntu-core-launcher
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 34 not upgraded.
Need to get 0 B/29.5 kB of archives.
After this operation, 0 B of additional disk space will be used.
Preconfiguring packages ...
(Reading database ... 286132 files and directories currently installed.)
Preparing to unpack .../ttf-mscorefonts-installer_3.4+nmu1ubuntu2_all.deb ...
mscorefonts-eula license has already been accepted
Unpacking ttf-mscorefonts-installer (3.4+nmu1ubuntu2) over (3.4+nmu1ubuntu2) ...
Processing triggers for fontconfig (2.11.94-0ubuntu1.1) ...
Processing triggers for update-notifier-common (3.168.3) ...
ttf-mscorefonts-installer: processing...
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Get:1 http://downloads.sourceforge.net/corefonts/andale32.exe [361 B]
Err:1 http://downloads.sourceforge.net/corefonts/andale32.exe                  
  404  Not Found
W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/andale32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
E: Failed to fetch https://ncu.dl.sourceforge.net/project/corefonts/the fonts/final/andale32.exe  404  Not Found

E: Download Failed
Setting up ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...
11

Here is the bug report on launchpad. The cause of the bug is http redirects on sourceforge.org which are not handled properly by the installer.

The author of the report provides two workarounds with detailed walkthrough:

  • The one is to cherrypick v3.6 from debian site as mentioned in other answers.
  • The other is to manually download the required files from sourceforge with wget which can handle the redirects nicely, then run dpkg-reconfigure and specify the directory with the downloaded files when asked.

Make a temporary directory and download fonts:

mkdir /tmp/mscoref
cd /tmp/mscoref
wget http://downloads.sourceforge.net/corefonts/{andale32.exe,arial32.exe,arialb32.exe,comic32.exe,courie32.exe,georgi32.exe,impact32.exe,times32.exe,trebuc32.exe,verdan32.exe,webdin32.exe}

then purge the failed package

sudo apt-get purge ttf-mscorefonts-installer

reinstall the package ignoring probable errors:

sudo apt-get install ttf-mscorefonts-installer

and finally:

sudo dpkg-reconfigure ttf-mscorefonts-installer

this will lead to this message:

enter image description here

Press enter; type the path to the downloaded files in the box (note: . does not work for me here):

enter image description here

and press enter again.

Now the fonts get installed smoothly:

....
Extracting cabinet: /tmp/mscoref/webdin32.exe
  extracting fontinst.exe
  extracting Webdings.TTF
  extracting fontinst.inf
  extracting Licen.TXT

All done, no errors.
All fonts downloaded and installed.

All credits should go to robingape from launchpad

9

The version 3.4 of the ttf-mscorefonts-installer is currently broken. Version 3.6 from the Debian repositories works fine. You can download and install the package accordingly (and thereby fix the error mentioned above):

wget http://ftp.us.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.6_all.deb
sudo dpkg -i ttf-mscorefonts-installer_3.6_all.deb

Alternative regional repositories are at https://packages.debian.org/sid/all/ttf-mscorefonts-installer/download.

This has fixed the above mentioned bug for me.

  • This worked on Ubuntu 14.04 after I installed cabextract with: sudo apt-get update sudo apt-get -f install – fuzzyhedge Jun 3 '17 at 20:21
2

Interestingly this bug is a bug of apt and not dpkg or wget. You can circumvent this by downloading in case of 16.04 (xenial)

http://packages.ubuntu.com/xenial/all/ttf-mscorefonts-installer/download

and install it manually as:

ubuntu@green: $ cd Downloads
ubuntu@green:~/Downloads $ dpkg --install ttf-mscorefonts-installer_3.6_all.deb
  • That URL leads to the package ttf-mscorefonts-installer_3.4+nmu1ubuntu2_all.deb which still cannot be installed with dpkg. The 3.6 version does work (at least for me), on the other hand. – Supernormal Jan 10 '17 at 21:52
0

Use this commands to fix problems:

sudo rm -rf /var/lib/update-notifier/package-data-downloads/partial/*
sudo apt-get --purge --reinstall install ttf-mscorefonts-installer\

Check other solutions here: How to make ttf-mscorefonts-installer package download fonts, after it says it installed?

  • 1
    This answer still results in a failure: W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/andale32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied) – Christopher Jan 22 '17 at 21:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.