0

I a question like this has been asked before, but none of the solutions I found have worked, and I think my problem is different, because it's more like Steam not detecting the library. Exact error message:

You are missing the following 32-bit libraries, and Steam may not run: libc.so.6

When I try run sudo apt-get install libc6:i386, it returns this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libc6:i386 is already the newest version (2.23-0ubuntu3).
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 gcc-5-multilib : Depends: libc6-dev-i386 (>= 2.11) but it is not going to be installed
 libc6-dev-x32 : Depends: libc6-dev-i386 (= 2.23-0ubuntu3) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I have tried apt-get -f install, which returns this error:

dpkg: error processing archive /var/cache/apt/archives/libc6-dev-i386_2.23-0ubuntu3_amd64.deb (--unpack):
 trying to overwrite '/usr/include/bits', which is also in package libc6-dev-amd64:i386 2.23-0ubuntu3
Errors were encountered while processing:
 /var/cache/apt/archives/libc6-dev-i386_2.23-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

It looks like my problem is that the file is there, but for some reason it is not detected by Steam.

  • sorry but this answer does work: askubuntu.com/questions/602637/… It is the missing package you need. Otherwise you really need to add to the question what you tried and why those things did not work. – Rinzwind Sep 24 '16 at 20:07
  • I have edited my question heavily, and would like you to unmark it as a duplicate, as I believe that my question is different. – APerson Sep 25 '16 at 7:01
  • 1
    What's the output of uname -m and apt-cache policy libc6-dev-i386 libc6-dev-amd64:i386? I'm curious what installed libc6-dev-amd64:i386 if you're on AMD64 architecture and you should probably remove it (native-architecture glibc development files are in libc6-dev). – David Foerster Sep 25 '16 at 7:16
  • uname -m: x86_64, apt-cache policy libc6-dev-i386 libc6-dev-amd64:i386: libc6-dev-i386: Installed: (none) Candidate: 2.23-0ubuntu3 Version table: 2.23-0ubuntu3 500 500 dk.archive.ubuntu.com/ubuntu xenial/main amd64 Packages libc6-dev-amd64:i386: Installed: 2.23-0ubuntu3 Candidate: 2.23-0ubuntu3 Version table: *** 2.23-0ubuntu3 500 500 dk.archive.ubuntu.com/ubuntu xenial/main i386 Packages 100 /var/lib/dpkg/status – APerson Sep 25 '16 at 9:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.