0

I was trying to fresh install Ubuntu 16.04 on my PC, Previously i was using 14.04. System was getting slow so i wanted to install fresh, I deleted the /, /boot, /swap and recreated.

While installing i did select encrypt /home and continue in UEFI MODE The process was terminated after Grub installation failed image

Please do the needful to fix this issue.

  • Turn on secure boot if it is off ... I had this problem... simple solution solved in my case the same problem..if it is on try turning it off.reboot and let me know – minigeek Sep 27 '16 at 19:15
1

For UEFI-install your hard-drive should have GPT-partition-table.You need to create ESP (EFI System Partition, 500MB, FAT32, boot-flag). If your drive has msdos-partition-table you should convert to GPT first. Or reinstall in legacy-mode.

Boot your Ubuntu-installer and choose Something else. Open terminal with Ctrl+Alt+T. Find out your partition-table-type:

sudo parted -l

Look for the entry Partition Table

IF Partition Table is GPT then reinstall in UEFI-mode, create ESP during Install.
IF Partition Table is msdos then reinstall in legacy-mode or convert to GPT
and then reinstall in UEFI-mode.

How to convert msdos to GPT:

sudo gdisk sdX    (for X type the correct letter for your drive)
Upon start, gdisk attempts to identify the partition type in use on the
disk. If  it finds valid GPT data, gdisk will use it. If gdisk finds a valid
MBR (msdos), it will attempt to  convert the MBR into GPT form. Upon exiting
with  the  'w'  option,  gdisk replaces the MBR or disklabel with a GPT.

The MBR-to-GPT conversion will leave at least one gap in the  partition
numbering  if  the original MBR used logical partitions. These gaps are
harmless, but you can eliminate them by using the 's' option, if you like.

Note:

How you boot is how you install. If you want to install in UEFI-mode, you have to boot the installer in UEFI-mode. If you want to install in legacy-mode, you have to boot the installer in legacy-mode. Just choose the correct boot-option when you start the installer.

  • Hi mook765! Thanks for your comments. I created EFI partition(250 MB) during installation and I successfully installed ubuntu 16.04. But the problem is it won't boot. When I boot it, it directly goes to bios settings after the appearance of black screen. What I do to boot my ubuntu 16.04.? Please do the needful. – Pechi Muthu Haridas Sep 25 '16 at 12:13
  • Have you checked if your drive has GPT-partition-table? – mook765 Sep 25 '16 at 12:29
  • No my drive in MBR partition. I manually created EFI partition based on this link: help.ubuntu.com/community/UEFI during installation. I think that is the problem. I don't know how to create FAT32(ESP) partition with boot/efi mount point using GParted. My technical knowledge is low. Please give me the solution. – Pechi Muthu Haridas Sep 26 '16 at 7:42
  • You need to convert to GPT-partition-table if you want to install in UEFI-mode, how to do that is described in the answer. (How to convert msdos to GPT) – mook765 Sep 26 '16 at 15:23
  • 1
    Hi mook765! Thanks for your comments. I converted my entire partition to GPT and I created EFI partion for uefi boot loader. And I successfully installed Ubuntu 16.04 in my PC. Now it is booting. Thanks. – Pechi Muthu Haridas Oct 3 '16 at 5:37
0

Here is a non-geeky way of fixing grub. Tried a tool "boot-repair" and it worked. Even worse, they got a graphical way too.

More detail is listed here: https://help.ubuntu.com/community/Boot-Repair

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.