I'm trying to compile the software "TrinityCore". The process is explained quite thoroughly here: https://trinitycore.atlassian.net/wiki/display/tc/Linux+Core+Installation

After installing the dependencies, which include libboost-all-dev I was using cmake as explained. It stopped configuring when looking for some boost libraries (see below).

The strange thing is that I installed the required packages and there are directories in


that match the names of the missing libraries.

I also tried the solution here: Cmake Couldn't find boost but unfortunately without success.

Does anybody know what I'm doing wrong?

Thanks in regards!

Here the exact error message:

  Unable to find the requested Boost libraries.

  Boost version: 1.58.0

  Boost include path: /usr/include

  Could not find the following static Boost libraries:


  No Boost libraries were found.  You may need to set BOOST_LIBRARYDIR to the
  directory containing Boost libraries or BOOST_ROOT to the location of
  Boost.  If you still have problems search on forum for TCE00020.
Call Stack (most recent call first):
  • /usr/include contains headers not libraries - did you check that the corresponding static libraries e.g. libboost_system.a exist (on 64-bit systems, they should be in /usr/lib/x86_64-linux-gnu/ I think). OTOH I'm not sure why it would be looking for static libs - iirc the cmake defaults to dynamic. – steeldriver Sep 24 '16 at 12:06

Strangely, only reinstalling Ubuntu Server 16.04.1 helped. Then, I didn't install


but only the packages required by Trinitycore. Now


is runnig after cmake without any problems.

By adding the options

-DBoost_<missing package>_RELEASE=/usr/include/boost/<missing package>/

cmake can find it. Odd, because these are just subdirectories of


which was already found by cmake.

  • Okay, this doesn't seem to really help since at the end of the configuring it says: WARNING: Target "common" requests linking to directory "/usr/include/boost/system". Targets may link only to libraries. CMake is dropping the item. – Markus Sep 24 '16 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.