6

Have installed ppa "Canonical Chromium Builds" team with

$ sudo add-apt-repository ppa:canonical-chromium-builds/stage

which previously installed chromium version 51.0.2704.79.

Am attempting to install the newest version of chromium available at the ppa for Precise.

$ lsb_release -a

returns

Description:    Ubuntu 12.04.1 LTS

When trying

$ sudo apt-get update
$ sudo apt-get install chromium-browser

the following is logged at terminal

Get:1 http://ppa.launchpad.net/canonical-chromium-builds/stage/ubuntu/ precise/main chromium-browser i386 52.0.2743.116-0ubuntu0.12.04.1.1015 

where the newest version in above ppa for Precise is listed as

chromium-browser 53.0.2785.89-0ubuntu0.12.04.1.1018 (2016-09-07)

Trying

$ sudo apt-cache policy chromium-browser

logs

Candidate: 52.0.2743.116-0ubuntu0.12.04.1.1015

How to install the latest version of the ppa? Or, alternatively, the latest version 53+ dev build of chromium-browser at Precise?

0

I looked at the repo's Packages.bz2 file for 12.04 and 16.04 and saw that there Packages.bz2 were not updated to point to the latest version of chromium available in the repo.

Maybe the maintainer forgot to do it

So I would recommend you to use another ppa or wait beacuse the repo's devel section which ,if I am right means that the update is still in testing process and not ready as considered by the maintainer .

And as you asked how can you install then you may use these commands:
cd /etc/apt/sources.list.d
sudo nano canonical-chromium-builds-ubuntu-stage-xenial.list
and change the line :
deb http://ppa.launchpad.net/canonical-chromium-builds/stage/ubuntu precise main
to
deb http://ppa.launchpad.net/canonical-chromium-builds/stage/ubuntu xenial main
and then run
sudo apt update && sudo apt install chromium-browser

Before editing the source file
After editing the source file

| improve this answer | |
  • Are you suggesting to install Xenial dist version of package at Precise? – guest271314 Sep 27 '16 at 15:03
  • Yup!!! You can try it.. – Jøê Grèéñ Sep 27 '16 at 15:59
  • Were you able to successfully install chromium at Precise using Xenial package? – guest271314 Sep 27 '16 at 16:22
  • To be clear I am a xenial user and installed many precise packages like Atom, conky themes, NoobsLab themes and I can you will be able to do it considering that you are in an LTS release and they are kept updated with the latest stable software... So in theory a xenial packages will install and run in precise – Jøê Grèéñ Sep 27 '16 at 16:26
  • Interesting. Have you done the same the other way? That is, install Xenial packages at Precise? Or newer dist packages at older dist? Found LTSEnablementStack, which appears to update Precise kernel to Trusty – guest271314 Sep 27 '16 at 16:37
0

The solution was to use aptitudes build-dep action, where dependencies for chromium-browser from "Canonical Chromium Builds" team were installed before installing chromium, resulting in version 52.0.2743.116 (Developer Build) Built on Ubuntu being successfully installed at Precise 12.04.1.

$ aptitude --help

Usage: aptitude [-S fname] [-u|-i]
       aptitude [options] <action> ...
  Actions (if none is specified, aptitude will enter interactive mode): 
 ..
 build-dep    - Install the build-dependencies of packages.
 ..

After adding ppa,

$ aptitude -v -V build-dep chromium-browser
Unable to satisfy the build-depends: Build-Depends: libgcrypt-dev.
Unable to satisfy the build-depends: Build-Depends: libexpat-dev.
Unable to satisfy the build-depends: Build-Depends: libpng-dev.
Unable to satisfy the build-depends: Build-Depends: libxslt-dev.
Unable to satisfy the build-depends: Build-Depends: libsrtp-dev.
Unable to satisfy the build-depends: Build-Depends: libgcrypt-dev.
Unable to satisfy the build-depends: Build-Depends: libexpat-dev.
Unable to satisfy the build-depends: Build-Depends: libpng-dev.
Unable to satisfy the build-depends: Build-Depends: libxslt-dev.
Unable to satisfy the build-depends: Build-Depends: libsrtp-dev.
The following NEW packages will be installed:
## list of packages
..
Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

      Upgrade the following packages:                                         
1)     gtk2-engines-pixbuf [2.24.10-0ubuntu6 (now, precise) -> 2.24.10-0ubunt
2)     libgail-common [2.24.10-0ubuntu6 (now, precise) -> 2.24.10-0ubuntu6.3 
3)     libgail18 [2.24.10-0ubuntu6 (now, precise) -> 2.24.10-0ubuntu6.3 (prec
4)     pciutils [1:3.1.8-2ubuntu5 (now, precise) -> 1:3.1.8-2ubuntu6 (precise

Accept this solution? [Y/n/q/?] y
The following NEW packages will be installed:
  binutils-gold [2.22-6ubuntu1.4]  chrpath [0.13-2build2]  
  dh-buildinfo [0.9ubuntu1]  gir1.2-gconf-2.0{a} [3.2.5-0ubuntu2]  
  gir1.2-gnomekeyring-1.0{a} [3.2.2-2]  
  libatk1.0-dev{a} [2.4.0-0ubuntu1]  
  libatomic-ops-dev [7.2~alpha5+cvs20101124-1ubuntu1]  
  libcairo-script-interpreter2{a} [1.10.2-6.1ubuntu3]  
  libcairo2-dev{a} [1.10.2-6.1ubuntu3]  libcap-dev [1:2.22-1ubuntu3]  
  libcups2-dev [1.5.3-0ubuntu8.7]  
  libevent-core-2.0-5{a} [2.0.16-stable-1ubuntu0.1]  
  libevent-dev [2.0.16-stable-1ubuntu0.1]  
  libevent-extra-2.0-5{a} [2.0.16-stable-1ubuntu0.1]  
  libevent-openssl-2.0-5{a} [2.0.16-stable-1ubuntu0.1]  
  libevent-pthreads-2.0-5{a} [2.0.16-stable-1ubuntu0.1]  
  libexif-dev [0.6.20-2ubuntu0.1]  libffi-dev [3.0.11~rc1-5]  
  libfontconfig1-dev{a} [2.8.0-3ubuntu9.2]  
  libfreetype6-dev{a} [2.4.8-1ubuntu2.3]  
  libgconf2-dev [3.2.5-0ubuntu2]  libgconf2-doc{a} [3.2.5-0ubuntu2]  
  libgdk-pixbuf2.0-dev{a} [2.26.1-1ubuntu1.5]  
  libgnome-keyring-dev [3.2.2-2]  libgtk2.0-dev [2.24.10-0ubuntu6.3]  
  libjpeg-dev [8c-2ubuntu7]  
  libjpeg-turbo8-dev{a} [1.1.90+svn733-0ubuntu4.4]  
  libjpeg8-dev{a} [8c-2ubuntu7]  libjsoncpp-dev [0.6.0~rc2-2]  
  libjsoncpp0{a} [0.6.0~rc2-2]  libnspr4-dev{a} [4.12-0ubuntu0.12.04.1]  
  libnss3-dev [2:3.23-0ubuntu0.12.04.1]  
  libpam0g-dev [1.1.3-7ubuntu2.3]  
  libpango1.0-dev{a} [1.30.0-0ubuntu3.1]  libpci-dev [1:3.1.8-2ubuntu6]  
  libpixman-1-dev{a} [0.30.2-1ubuntu0.0.0.0.3]  
  libspeechd-dev [0.7.1-6ubuntu3]  libspeechd2{a} [0.7.1-6ubuntu3]  
  libspeex-dev [1.2~rc1-3ubuntu2]  libudev-dev [175-0ubuntu9.10]  
  libwebp-dev [0.1.3-2.1ubuntu1]  libwebp2{a} [0.1.3-2.1ubuntu1]  
  libxcb-render0-dev{a} [1.8.1-1ubuntu0.2]  
  libxcb-shm0-dev{a} [1.8.1-1ubuntu0.2]  
  libxcomposite-dev{a} [1:0.4.3-2build1]  
  libxcursor-dev{a} [1:1.1.12-1ubuntu0.1]  
  libxdamage-dev{a} [1:1.1.3-2build1]  
  libxfixes-dev{a} [1:5.0-4ubuntu4.4]  libxft-dev{a} [2.2.0-3ubuntu2]  
  libxi-dev{a} [2:1.7.1.901-1ubuntu1~precise3]  
  libxinerama-dev{a} [2:1.1.1-3ubuntu0.1]  
  libxml2-dev [2.7.8.dfsg-5.1ubuntu4.15]  
  libxrandr-dev{a} [2:1.3.2-2ubuntu0.3]  
  libxrender-dev{a} [1:0.9.6-2ubuntu0.2]  libxss-dev [1:1.2.1-2]  
  libxtst-dev [2:1.2.0-4ubuntu0.1]  
  ninja-build [1.3.4-1.1ubuntu0.14.04.1~12.04]  
  x11proto-composite-dev{a} [1:0.4.2-2]  
  x11proto-damage-dev{a} [1:1.2.1-2]  
  x11proto-fixes-dev{a} [1:5.0-2ubuntu1]  
  x11proto-randr-dev{a} [1.4.0+git20120101.is.really.1.4.0-0ubuntu1~precise2]  
  x11proto-record-dev{a} [1.14.1-2]  
  x11proto-render-dev{a} [2:0.11.1-2]  
  x11proto-scrnsaver-dev{a} [1.2.1-2]  
  x11proto-xinerama-dev{a} [1.2.1-2]  
The following packages will be upgraded:
  binutils [2.22-6ubuntu1 -> 2.22-6ubuntu1.4]  
  fontconfig-config [2.8.0-3ubuntu9.1 -> 2.8.0-3ubuntu9.2]  
  gir1.2-gdkpixbuf-2.0 [2.26.1-1 -> 2.26.1-1ubuntu1.5]  
  gtk2-engines-pixbuf [2.24.10-0ubuntu6 -> 2.24.10-0ubuntu6.3]  
  libcups2 [1.5.3-0ubuntu4 -> 1.5.3-0ubuntu8.7]  
  libevent-2.0-5 [2.0.16-stable-1 -> 2.0.16-stable-1ubuntu0.1]  
  libfontconfig1 [2.8.0-3ubuntu9.1 -> 2.8.0-3ubuntu9.2]  
  libfreetype6 [2.4.8-1ubuntu2 -> 2.4.8-1ubuntu2.3]  
  libgail-common [2.24.10-0ubuntu6 -> 2.24.10-0ubuntu6.3]  
  libgail18 [2.24.10-0ubuntu6 -> 2.24.10-0ubuntu6.3]  
  libgdk-pixbuf2.0-0 [2.26.1-1 -> 2.26.1-1ubuntu1.5]  
  libgdk-pixbuf2.0-common [2.26.1-1 -> 2.26.1-1ubuntu1.5]  
  libgtk2.0-0 [2.24.10-0ubuntu6 -> 2.24.10-0ubuntu6.3]  
  libjpeg-turbo8 [1.1.90+svn733-0ubuntu4.1 -> 1.1.90+svn733-0ubuntu4.4]  
  libpam0g [1.1.3-7ubuntu2 -> 1.1.3-7ubuntu2.3]  
  libpci3 [1:3.1.8-2ubuntu5 -> 1:3.1.8-2ubuntu6]  
  libpixman-1-0 [0.24.4-1 -> 0.30.2-1ubuntu0.0.0.0.3]  
  libudev0 [175-0ubuntu9.2 -> 175-0ubuntu9.10]  
  libxcb-render0 [1.8.1-1ubuntu0.1 -> 1.8.1-1ubuntu0.2]  
  libxcb-shm0 [1.8.1-1ubuntu0.1 -> 1.8.1-1ubuntu0.2]  
  libxcursor1 [1:1.1.12-1 -> 1:1.1.12-1ubuntu0.1]  
  libxfixes3 [1:5.0-4ubuntu4 -> 1:5.0-4ubuntu4.4]  
  libxi6 [2:1.6.0-0ubuntu2 -> 2:1.7.1.901-1ubuntu1~precise3]  
  libxinerama1 [2:1.1.1-3build1 -> 2:1.1.1-3ubuntu0.1]  
  libxml2 [2.7.8.dfsg-5.1ubuntu4.2 -> 2.7.8.dfsg-5.1ubuntu4.15]  
  libxrandr2 [2:1.3.2-2 -> 2:1.3.2-2ubuntu0.3]  
  libxrender1 [1:0.9.6-2build1 -> 1:0.9.6-2ubuntu0.2]  
  libxtst6 [2:1.2.0-4 -> 2:1.2.0-4ubuntu0.1]  
  pciutils [1:3.1.8-2ubuntu5 -> 1:3.1.8-2ubuntu6]  
The following packages are SUGGESTED but will NOT be installed:
  libcairo2-doc  libgtk2.0-doc  libpango1.0-doc  speech-dispatcher

$ sudo aptitude -v -V install chromium-browser
The following NEW packages will be installed:
  chromium-browser [52.0.2743.116-0ubuntu0.12.04.1.1015]  
  chromium-browser-l10n{a} [52.0.2743.116-0ubuntu0.12.04.1.1015]  
  chromium-codecs-ffmpeg-extra{a} [52.0.2743.116-0ubuntu0.12.04.1.1015]   
| improve this answer | |
0
+100

The PPA you mention is a testing site used just before upload to Ubuntu main. Things there are either new and broken and not ready to use, or landing in the distro anyway in a few days. You shouldn't use it unless asked to.

It appears that the major version you are interested in for Precise is currently building at the time of this post as shown i386 and amd64

Edit: Both of the above failed to build on icy01-31. The build logs for amd and i386 may be of interest to you.

Perhaps patience will pay off. I would assume that they will be released if they are successfully built. I believe once successful it will be available here

Source:

https://launchpad.net/~canonical-chromium-builds/+archive/ubuntu/stage

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.