4

So, I decided to try installing ubuntu 16.04.1 on my Windows 10 computer, and attempting to do a dual boot. This issue seems pretty common, but for some reason I just cant get the friggin GRUB menu to show up at all; it just boots me right into windows 10.

I've turned off Fastboot, and tried to turn off secureboot but couldn't find it in my BIOS lol.

I tried booting from the live USB into ubuntu, and running

sudo grub-install

but all that did was throw up an error message.

I also tried switching between legacy and UEFI booting in the BIOS, that also didn't do anything. I remember when I installed ubuntu it asked something about UEFI, and how things might go bad if I installed it in that mode, so maybe I should go reinstall ubuntu in UEFI? Or will that actually break stuff?

So I'm a total noob and have no idea as to what I'm doing... Any help please? :P

Edit: I've figured out that windows is in BIOS mode, not UEFI. I reinstalled ubuntu onto my drive partition, making sure that it is in non-UEFI mode, and got the same result: No GRUB. I messed around in my BIOS's boot order, but all it gave me was the option to boot from either of my two hard discs.

Edit 2: Boot-Repair log

  • Have you tried changing boot order in your BIOS? My sister's laptop has an entry for Grub, and a separate entry for the Windows bootloader. Not sure if it's UEFI or not, but it's a good place to start. – SuperSluether Sep 22 '16 at 21:35
  • 1
    As far as installing in UEFI, everything should work fine, as long as both OSes are installed in the same mode. So either Windows and Ubuntu are both UEFI, or they both are not. – SuperSluether Sep 22 '16 at 21:35
  • Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info – oldfred Sep 22 '16 at 23:19
  • Added BootInfo summary – TheFinal1 Sep 22 '16 at 23:40
  • While system is BIOS/MBR it mentions left over gpt. Windows installs in BIOS mode convert previous gpt partitioned drives incorrectly to MBR. They leave the backup gpt partition table at end of drive. You need to use fixparts to remove backup gpt table. FixParts is the easiest way to remove the stray GPT data. GPT fdisk (gdisk or sgdisk) can do it, but the procedure's a bit more involved. rodsbooks.com/fixparts – oldfred Sep 23 '16 at 3:54
3

Try running boot repair when you are on Ubuntu or boot into ubuntu from a LIVECD.. It fixed the issue of grub not working in my case : Follow this: https://help.ubuntu.com/community/Boot-Repair

  • indeed - burn boot repair image to usb stick and keep it around. Major Wind0w$ updates seem to break grub and I find myself having to run boot repair every so often – gingamann Sep 23 '16 at 7:00
  • You're the best. Ran boot repair, rebooted, BAM! GRUB! Of course, afterwards it didn't show windows, but I ran update-grub and it seems to have fixed it ;b – TheFinal1 Sep 23 '16 at 7:54
  • 1
    This problem occurs when you install ubuntu first and then windows in a dual boot which overwrites grub with Windows bootloader.. Boot repair is the optimal solution – Sumit Kumar Sep 23 '16 at 8:52
  • Well.. I installed windows first, then ubuntu; but nonetheless boot repair got it working ;P – TheFinal1 Sep 23 '16 at 21:39
  • Boot repair hosed my system. Now I can't boot to either. – pakman Sep 13 '17 at 1:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.