1

This question already has an answer here:

I am running Linux Ubuntu 16.04 LTS, and I wasn't able to run my Operating System anymore after my latest update attempt. Here's what happened:

  1. I first ran the upgrade procedures through terminal as usual: sudo apt-get update, sudo apt-get upgrade, sudo apt-get autoremove, and sudo apt-get autoremove.
  2. However, I was told that 4 not upgraded, so I decided to run Software Updater as well, and there was indeed updates available concerning Ubuntu base. I installed those successfully, and decided to proceed with restart my system.

After the restart, my system doesn't start though. Instead, I receive the following error message:

[ 1.452270] genirq: Flags mismatch irq 0. 00000080 (nvme0q0) vs. 00015a00 (timer)
[ 1.452551] iounmap: bad address ffffc90001b88000
Scanning for Btrfs filesystems
Gave up waiting for root device. Common problems:
 - Boot args (cat /proc/cmdline)
  - Check rootdelay= (did the system wait for the right device?)
  - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT! UUID=a5ccaf22-ffde-44c2-8c59-84a851f9fd90 does not exist. Dropping to shell!

BusyBox v1.222.1 (Ubuntu 1:1.22.0-15ubuntu1) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs)

I was able to recover my system through the +Advanced options for Ubuntu, which I opened after. There I had total of nine choices, three options for each version. I first tried the recovery version of the latest one, but it didn't work. After that, I tried the generic version of the second latest, and — thank God — that one managed to recover my system!

UPDATE: The three version I have available are the following, running from the latest to the oldest: 1) Ubuntu, with Linux 4.4.0-3**9** generic, 2) Ubuntu, with Linux 4.4.0-3**8** generic, and 3) Ubuntu, with Linux 4.4.0-3**7** generic. With the second one I was able to start the system.

What went wrong? How can I fix it? Now I am afraid to update my system :-( Please help!!!

marked as duplicate by mikewhatever, edwinksl, Panther, Eric Carvalho, karel Sep 23 '16 at 13:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Sounds like a kernel bug to me. If the advice mike gave you does not work, continue to use an old kernel and file a bug report against the new kernel. – Panther Sep 22 '16 at 17:58
  • Definitely after incorrectly updating your system, the boot module has become corrupted. Boot Ubuntu into a safe mode and run sudo dpkg --configure -a and sudo apt-get dist-upgrade. You might then want to reinstall grub. – John Strood Sep 22 '16 at 18:30
  • @mikewhatever I checked the thread you gave, but it's mostly about booting from a LiveCD, which is not the case here. – Jayaguru-Shishya Sep 23 '16 at 8:12
  • @Djack Thanks for your respnse. Any idea where I ran the update procedures incorrectly? All I did was to run the for above-mentioned commands via Terminal and then the Software Update. I will try the steps you adviced, thanks again Djack! – Jayaguru-Shishya Sep 23 '16 at 8:14
  • @Djack Sorry for this noobish question, but is safe mode the same as the recovery mode? I just booted my system and I have three alternatives in the +Advanced options for Ubuntu: 1) ...generic, 2) ...generic (upstart), and 3) ...generic (recovery mode). I tried the number 3), but it brought me to a window called Recovery Menu (filesystem state: read-only), which had eight options: 1) clean, 2) dpkg, 3) failsafeX, 4) fsck, 5) grub, 6) network, 7) root, and 8) system-summary. There's no console where to execute the commands you mentioned, though. Any ideas? :-O – Jayaguru-Shishya Sep 23 '16 at 8:25
1

I got the exact same problem. Downgraded to 4.4.0-38, then blocked -39 from being installed, by pinning that version with priority -1. This is a kernel regression, which might show up in later 4.4.0 updates too. Hopefully it is fixed in the kernel version shipping with Ubuntu 16.10. The -39 kernel fails to detect my NVMe SSD that I'm booting from, while the -38 kernel works perfectly. According to the release notes there were two fixes to the NVMe code: (LP: #1602724) and (LP: #1620317). It is possible one of these broke the NVMe detection.

  • Reported this to LaunchPad: bugs.launchpad.net/ubuntu/+source/linux/+bug/1627040 – Fairglow Sep 23 '16 at 14:08
  • From what I gather, this is not a duplicate of that other question. But a new issue, where NVMe SSD's are not detected by the 4.4.0-39 kernel. Downgrading to 4.4.0-38 is the solution and holding off upgrading the kernel until the regression is solved. – Fairglow Sep 23 '16 at 14:14
  • Thanks! I struggled with making a Kernel Bug report myself (askubuntu.com/questions/828627/… and askubuntu.com/questions/828687/…). Anyway, could you please help me a bit? :-) I made a question to @Djack in a reply above, the question is rather noobish since a newbie I am, but still... Thanks :-) – Jayaguru-Shishya Sep 24 '16 at 10:07
  • Unfortunately I don't have any experience with any safe mode and cannot tell you what it is. The recovery mode drops you down in a busybox environment before the system is booted, which means you do not have access to all the tools in your system, unless you can mount it and maybe chroot into it. – Fairglow Sep 24 '16 at 10:49
  • 1
    That is to be expected, since you are still in the initramfs. You need to properly mount the real filesystem before you can run the package manager. The bug was solved in linux-image-4.4.0-41 which is available now; start up the system on the -38 kernel and upgrade you system to the latest kernel. That should solve the problem. – Fairglow Sep 29 '16 at 9:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.