34

Just got the Firefox 49 update (yay!)

But Netflix still wants to install Silverlight (boo!)

How can I watch Netflix in Firefox, as has been advertised?

  • 2
    Your linked article had this line "It’s unlikely that Netflix and company will flip the switch for Linux Firefox users right away, so some short-term user-agent switching may be necessary (as it was on Chrome to begin with)." – Anwar Sep 22 '16 at 14:48
  • I can't even get Netflix to play on Firefox on Windows, which the article claims is already possible, so I think Netflix is currently only allowing it for Chrome regardless of Firefox's technical support for it. Changing the user agent as stated below seems like the only way. – Aaron Franke Sep 22 '16 at 15:32
38

As wisely mentioned in comments: if you have this problem, contact Netflix support about it. It's a problem to be fixed on their side, and the more complains they'd get, the faster it get fixed.


A solution by GizmoChicken:

Is anyone able to play Netflix? With the original user agent it requests to install silverlight With chrome user agent it plays, but with tearing and high cpu load.

Netflix plays for me on Firefox 49 when using the following User-Agent entry:

Linux / Chrome 53: Mozilla/5.0 (X11; Ubuntu; Linux x86_64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/53.0.2785.34 Safari/537.36

Sometimes I have to hit "refresh" to start a video. I don't recall ever having to do that with Chrome. So it's still not perfect.

===================================== (edit by OP)

Before using the user agent string above (which worked) I had to do two other things.

  1. Get Firefox to install the Widevine plugin by ticking the box on Preferences/Content labeled Play DRM Content.
  2. Install User Agent Overrider extension. Then go to the extension's preferences and add the user agent string above.

Then just select the Linux / Chrome 53 user agent, go to Netflix.com, and Bob's yer uncle.

Edit 2: This also works on 32 bit Ubuntu! Woo hoo!

Edit 3: At least as of April 2017, 32 bit no longer works, but the user agent workaround is no longer required.

Edit 4: One of the many awesome enhancements in Firefox Quantum is that Netflix works again in 32 bit! (Dec 2017)

  • 1
    Thanks, that worked. I'm going to edit your answer a bit to include all the steps I had to do. – Organic Marble Sep 22 '16 at 15:29
  • 2
    @TenLeftFingers from a quick search you could try this extension to override a user agent only for Netflix. – Hi-Angel Sep 23 '16 at 16:23
  • 2
    Props to Amazon Video for this working immediately upon the upgrade to Firefox 49. Upon starting video on Amazon, you just get prompted to install Widevine, which will of course work with Netflix after the above User Agent spoofing. – Canuteson Sep 26 '16 at 3:20
  • 8
    I'd also highly recommend everyone contact Netflix asking them to fix this. Spoofing our user-agent is something we shouldn't have to do. – Canuteson Sep 26 '16 at 12:58
  • 2
    This user agent works for my firefox netflix access: Mozilla/5.0 (Windows NT 10.0; rv:41.0) Gecko/20100101 Firefox/49.0 – ubfan1 Oct 27 '16 at 4:48
2

download vlc media player.

sudo apt-get update
sudo apt-get install vlc browser-plugin-vlc

I guess vlc downloads the necessary libraries, but Netflix now plays with absolutely no problem in Firefox 54.

Worth noting this also worked when I was running Firefox 47.

protected by Community Dec 24 '16 at 0:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.