0

I use 3 browsers in my Ubuntu Desktop: chromium-browser (installed from ubuntu's repositories), google-chrome (installed stable version) and firefox (installes from ubuntu's repositories).

Today I had to install icedtea to run a java applet in firefox (it was a secure applet) and everything went OK. Often I browse using chromium but I have google-chrome installed too cause I use a private organization website which for some reason seems to have problems with chromium managing my user session.

Everything went OK until my google-chrome and chromium stopped working, they just freezed. I tried to reset my config by deleting chromium and chrome folder from ~/.config, also cleared corresponding ~/.cache but I could not get them to work properly again. After this I uninstalled them, first directly through dpkg with "dpkg -r" to remove and also "dpkg -P" to purge. After reinstalling them I could get chrome to work but it got stucked at "checking..." when trying to install extensions which I really need. About chromium it hangs when I try to access settings.

Finally I've tried to purge using "apt-get -purge" and also removing ~/.config and ~/.cache but the same problems persist. I've totally run out of ideas about what can I do to fix the problems. Any suggestions will be appreciated.

ALSO Im using ubuntu with the xubuntu-desktop package installed but I don't think thats causing any problems.

Thank you for help!

  • Have you tried removing icedtea? – Aaron Franke Sep 21 '16 at 23:11
  • One or more of those extensions you think you need but probably don't is definitely causing it; it was causing it before and it is causing it now, clear as water, because: both failed at the same time [following an addon update]. – user589808 Sep 22 '16 at 1:42
  • I've tried to revert my system to a previous state removing icedtea which is the only software I've recently installed but nothing changed. However this was expected since icedtea is a firefox's plugin which shouldn't affect chrome or chromium neither. About the extensions causing the problem it doesn't make any sense to me because I've purged the browsers and removed all config and cache files associated with them and after that the problem keeps going. Also I have two laptops where I use those browsers with the same addons and both of them work perfectly. Any other ideas? – Greesoft Sep 22 '16 at 9:04
  • Yes, you may have reinstalled, purged and all, but as soon as one or more of that extensions are installed (automatically if you login anywhere with your Google account, GMail, Youtube, etc....) everything becomes the same as before. Whether the same extensions are installed and not causing issues is irrelevant, hardware is different and so is its interactions with software. But, since your already made up your mind, I have nothing else to do here. Bye. – user589808 Sep 22 '16 at 18:16
  • I 've not logged in my google account using the browsers, the problem keeps happening after a fresh installation and before any operation is performed with except trying to access settings in chromium or trying to download any extension (no matter if it is a totally new one) in chrome. About the hardware point I can use another linux partition with the same OS installed which is not causing any problems. Something that is not in the /usr/share, /etc/, ~/.config/ or ~/.cache/ should be causing the misbehavior. – Greesoft Sep 22 '16 at 19:33
0

I've fixed the problem with google-chrome installing an older version. The current chrome version when this problem happened was 53.x, the older version I've installed was 42.x.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.