5

In my work laptop I am running Ubuntu Gnome 16.04.1 and I am not being able to configure Gnome Terminal to use the dark theme.

In my home computer I am using Arch Linux and Gnome Terminal has a checkbox that allows me to switch to the dark theme.
At first thought that it may be caused by Arch using a newer version of Gnome Terminal than Ubuntu. But the thing is that before Arch I was running Debian 8, and I had the same option available in Gnome Terminal.

Why is this option not available in Ubuntu?

1
4

Why? Because Ubuntu GNOME developers decided to rip off that option saying "It's more trouble than it's worth" . But it will be available from Gnome Terminal 3.19, which means we will see it in 16.10. (Thanks to egmont for correcting me on that it wasn't Ubuntus decision)

But you can enable Dark theme variant using

GTK_THEME=Adwaita:dark gnome-terminal 

command.

If you want you can even change the EXEC line in .desktop file of gnome terminal

Exec=env GTK_THEME=Adwaita:dark gnome-terminal 

Another option is to enable Dark variant for all applications using Gnome Tweak Tool. Install it, open, and in General Tab select Use Dark Theme option

Check this question for more

9
  • It wasn't Ubuntu ripping off this option. Mainstream gnome-terminal removed it temporarily due to certain technical problems. It's back and I think it's going to be there in Yakkety.
    – egmont
    Sep 22 '16 at 8:04
  • Do you have the bug link @egmont? I thought it was Ubuntu. Thanks for the info
    – Anwar
    Sep 22 '16 at 8:06
  • 1
    Thank you very much! I am going to modify the .desktop file for Gnome Terminal so it always uses the dark theme. BTW, sad to see Ubuntu removing this configuration option :(
    – crbelaus
    Sep 22 '16 at 8:49
  • @crbelaus Once again, it was not Ubuntu removing this option.
    – egmont
    Sep 22 '16 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.