3

I have updated my desktop pc to kernel 4.4.0-38 from 4.4.0-36 (that was ok). After restart I couldn't log in into my computer anymore.

With advanced from grub, i selected the old 4.4.0-36 kernel and tried to delete the new one 4.4.0-38.

Details of the bug mentioned above. When trying to delete kernel with:

sudo apt-get purge linux-image-4.4.0-34-generic

=>

The following packages have unmet dependencies:
linux-headers-4.4.0-38-generic : Depends: linux-headers-4.4.0-38 but it is not going to be installed 
E: Unmet dependencies.

or

sudo apt-get purge linux-image-4.4.0-38-generic

=>

The following packages have unmet dependencies: linux-headers-4.4.0-38-generic : Depends: linux-headers-4.4.0-38 but it is not going to be installed 
linux-image-extra-4.4.0-38-generic : Depends: linux-image-4.4.0-38-generic but it is not going to be installed
linux-image-generic-lts-xenial : Depends: linux-image-4.4.0-38-generic but it is not going to be installed
E: Unmet dependencies.

and

sudo apt-get -f install

WON'T resolve it.

I found this question Not enough free disk space when upgrading and used it to free up space on my ubuntu partition.

As a temporary fix I used this Set "older" kernel as default grub entry to set the default kernel as 4.4.0-36 in order to use the computer.

  • The standard kernel for 14.04 is 3.13.0-96-generic, at this time (at least in 64-bit, which is what I run). What makes you think 4.4.0-38-generic will work with 14.04? The fact other 4.4.* kernels will work doesn't mean newer builds are compatible... – Zeiss Ikon Sep 29 '16 at 19:21
  • Don't remove the new kernel. Instead have a look at How can I boot with an older kernel version?. After that it should be much easier to isolate and fix the issue with the newer kernel. – David Foerster Sep 29 '16 at 20:32
  • @ZeissIkon Hi.The system upgraded to 4.4.0-38, i just accepted the update. Anyway Ubuntu is no longer serviced for older than 4. Kernels in 14.04 LTS. – marius-ciclistu Sep 30 '16 at 5:57
  • @DavidFoerster Hi. What I explained above is done in an older kernel(4.4.0-36).In 38 I can't log in. – marius-ciclistu Sep 30 '16 at 5:59
  • @ZeissIkon 14.04 is on topic. Users have every right to use a different kernel, that doesn't make their question off topic. – terdon Sep 30 '16 at 11:40
1

I have the same issue. I used Synaptic; searched for 4.4.0-38; marked for removal; apply. After, apparently redundant, not required, I ran "suso update-grub" then rebooted. Just for sanity, after reboot, I ran "sudo apt-get autoremove" then "sudo apt-get clean" then "sudo apt -f install"

I rebooted, again, and all was well, running kernel 3.19.0-69.

Then I ran the system tools - administration - software updater, which started to re-install 4.4.0-68. I cancelled the system update. Still Googling for a permanent fix for not being able to log into 4.4.0-38.

I can't take credit for the following - found them online. I've successfully used them all:

Show all saved versions of kernel - Ubuntu

dpkg -l linux-image-\* | grep ^ii

Show all kernels and headers that can be removed, excluding the current running kernel - Ubuntu

kernelver=$(uname -r | sed -r 's/-[a-z]+//') dpkg -l linux-{image,headers}-"[0-9]*" | awk '/ii/{print $2}' | grep -ve $kernelver

After upgrading kernels and rebooting to test it, you can remove all other old kernels with: (Ubuntu)

sudo apt-get purge $(dpkg -l linux-{image,headers}-"[0-9]*" | awk '/ii/{print $2}' | grep -ve "$(uname -r | sed -r 's/-[a-z]+//')")
  • Hi. Your second command doesn't work on mine. It says grep: option requires an argument -- 'e' Usage: grep [OPTION]... PATTERN [FILE]... Try 'grep --help' for more information. – marius-ciclistu Sep 30 '16 at 6:12
  • Hi. David Foerster helped me and I'll write(or he will) an answear to this problem. Now I'm loged in 4.4.0-45 kernel and it seems ok. – marius-ciclistu Oct 29 '16 at 20:48
1

After a discussion with David Foerster I read this apt-get: No space left on device (12.04) and I found out about inodes being at 1% free space . You can ckeck this using:

df -ih /usr/src

and my result was:

Filesystem     Inodes IUsed IFree IUse% Mounted on
/dev/sda6        550K  540K   11K   99% /

Before I ran into this problem, i found this question Not enough free disk space when upgrading and used it to free up space on my ubuntu partition but didn't free up inodes space. So using the above question apt-get: No space left on device (12.04) I did that and now my problem is solved.

From now on I'll free up space using Not enough free disk space when upgrading and this apt-get: No space left on device (12.04) to avoid this kind of problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.