2

I have bought a BQ Aquaris E5 Android edition (because I can't find an Ubuntu edition one) and want to install Ubuntu on it. I have a Dell Precision M6300 with Ubuntu 14.04 available.

The phone has Android version 4.4.4 in Settings - About phone. It is also worth noting that in Settings - Developer options, there is no "OEM unlock".

BQ give a how-to guide on installing ubuntu on the Aquaris E4.5 and E5 here.

The guide can be summarised as follows (using an Ubuntu PC):

  1. Download the SP Flash tool and the firmware for Aquaris E5 Ubuntu Edition. Links to the Spanish download page are provided in the guide. English version is here.

  2. Decompress the downloaded files. The guide suggests using Win-RAR or 7-zip. Archive Manager does the job, and is installed on Ubuntu 14.04 by default.

  3. Execute the MTK Flash Tool. For Ubuntu 14.04, remove modemmanager with sudo apt-get remove modemmanager, restart udev with sudo service udev restart, check if the kernel module cdc_acm has been removed with lsmod | grep cdc_acm, and if that command returns nothing then reinstall with sudo modprobe cdc_acm. Change directory (cd) to where the SP Flash tool has been decompressed. Grant execute permissions for the necessary executables with chmod +x flash_tool and chmod +x flash_tool*. Finally execute with sudo ./flash_tool.sh.

  4. Prepare the MTK Flash Tool to carry out a hard reset. Click the "Scatter-loading" button. Navigate to where the firmware is decompressed. Select the text file, which will have a name similar to "MT6577_Android_scatter.txt" (in my case it was "MT6582_Android_scatter.txt") and press "Open". Click the drop-down menu button and select "Firmware Upgrade". Press the "Download" button.

  5. Carry out the hard reset. Turn your phone off. Connect it to your PC using the USB to micro-USB cable. The process should start. When it is finished a window with a green circle and the word OK will appear. Then you can close it, disconnect the phone and start up.

Where I have been encountering difficulties is with the last step, step 5. When I connect the powered off phone, it vibrates, the "bq" logo appears on the phone screen, a lot of lines appear on the PC terminal from where the flash tool was started, and then nothing happens until a timeout error appears an hour later.

jlam@m6300:~/Desktop/SP_Flash_Tool_exe_Linux_v5.1612.00.100$ ./flash_tool.sh
QGtkStyle was unable to detect the current GTK+ theme.
QThread::setPriority: Cannot set priority, thread is not running
"08-21-2016" 
QObject::moveToThread: Cannot move objects with a parent

(At this point I click the Download button)

Connecting to BROM...
Scanning USB port...
Search usb, timeout set as 3600000 ms

(At this point I connect the phone)

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0

add@/module/usb_storage

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/scsi_host/host4

add@/bus/usb/drivers/usb-storage

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0/4:0:0:0

add@/devices/virtual/bdi/11:1

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0/4:0:0:0/block/sr1

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0/4:0:0:0/scsi_device/4:0:0:0

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0/4:0:0:0/scsi_generic/sg2

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0/4:0:0:0/bsg/4:0:0:0

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0/4:0:0:1

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0/4:0:0:1/scsi_disk/4:0:0:1

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0/4:0:0:1/scsi_device/4:0:0:1

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0/4:0:0:1/scsi_generic/sg3

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0/4:0:0:1/bsg/4:0:0:1

change@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0/4:0:0:0/block/sr1

add@/devices/virtual/bdi/8:16

add@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0/4:0:0:1/block/sdb

change@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0/4:0:0:1/block/sdb

change@/devices/pci0000:00/0000:00:1a.7/usb1/1-4/1-4:1.0/host4/target4:0:0/4:0:0:1/block/sdb

(At this point nothing happens until timeout)

Timeout(3600000 ms) for searching USB port!
SearchUSBPortPool failed!
Failed to find USB port
Connect BROM failed: S_TIMEOUT
Disconnect!
BROM Exception! ( BROM ERROR : S_TIMEOUT (1042)


[HINT]:
)((ConnectBROM,../../../flashtool/Conn/Connection.cpp,85))

BROM ERROR S_TIMEOUT

I have one theory that when the battery charging screen comes on the flashing stops. The Aquaris E5 battery cannot be removed. The options give "with battery", "without battery" and "auto detect" options, but none of these seem to work.

I have tried all 6 USB sockets on this machine. I have tried 2 different cables. All produce the same result.

I have tried both the default "high speed" and the other selection: "full speed". (Not on all 6 sockets). Same result.

How do I successfully install this without the download freezing and giving the timeout error?

UPDATE: I have been trying the following link as an alternative method of installing Ubuntu https://developer.ubuntu.com/en/phone/devices/installing-ubuntu-for-devices/

At first (Android 4.4.4), neither adb nor fastboot worked correctly: adb did not detect any devices (even after using the adb kill-server command), and fastboot gave the incorrect device number and wouldn't reboot nor perform the oem unlock function. Upgrading to Lollipop resulted in adb working correctly, but fastboot was still not working. Upgrading to Android 6.0.1 resulted in fastboot also working correctly and ubuntu-device-flash seems to work in principle (when preceded by the sudo command).

However, this is what I am getting at the moment:

jlam@VEC-ubuntu-precision-m6300:~/Desktop/VEGETA01A-S23A_BQ_L100EN_1013_160524$ sudo ubuntu-device-flash touch --channel=ubuntu-touch/stable/bq-aquaris.en --bootstrap
2016/09/29 00:10:15 Expecting the device to be in the bootloader... waiting
2016/09/29 00:10:15 Device is |MSM8916|
2016/09/29 00:10:15 Device MSM8916 not found on server https://system-image.ubuntu.com channel ubuntu-touch/stable/bq-aquaris.en

I have also tried SP Flash tool again with Android 6.0.1. Same result as before.

UPDATE 2 29th September 2016: I can get round the MSM8916 error by using the option --device="vegetahd". Still not there yet.

This is what I got yesterday, though I had executed the command with the phone powered off, not in fastboot mode:

jlam@VEC-ubuntu-precision-m6300:~/Desktop/SP_Flash_Tool_exe_Linux_v5.1612.00.100$ sudo ubuntu-device-flash touch --channel=ubuntu-touch/stable/bq-aquaris.en --bootstrap --device="vegetahd"
2016/09/29 00:49:22 Device is |vegetahd|
2016/09/29 00:49:22 Flashing version 15 from ubuntu-touch/stable/bq-aquaris.en channel and server https://system-image.ubuntu.com to device vegetahd
66.97 MB / 66.97 MB [===============================================================] 100.00 % 2.39 MB/s 
70.78 MB / 70.78 MB [===============================================================] 100.00 % 2.21 MB/s 
298.13 MB / 298.13 MB [=============================================================] 100.00 % 5.35 MB/s 
/home/jlam/.cache/ubuntuimages/gpg/image-master.tar.xz
/home/jlam/.cache/ubuntuimages/gpg/image-signing.tar.xz
/home/jlam/.cache/ubuntuimages/ubuntu-touch/stable/bq-aquaris.en/vegetahd/version-15.tar.xz
/home/jlam/.cache/ubuntuimages/pool/custom-7ee762289981fe54f1cd374a17c6aabaf2720fb8d5b5a5b2e56e860032b3eb16.tar.xz
/home/jlam/.cache/ubuntuimages/pool/device-ff4a9b2ca3c4c0110b0d7fc05deb556b5634c213f450bd9da1b9ad2a8f09e215.tar.xz

I came down in the morning and it was still here, so I put the phone into fastboot mode at this point

2016/09/29 08:58:23 Can't boot recovery image                                              

This is what happened when I repeated the command this morning, with the phone in fastboot mode:

jlam@VEC-ubuntu-precision-m6300:~/Desktop/SP_Flash_Tool_exe_Linux_v5.1612.00.100$ sudo ubuntu-device-flash touch --channel=ubuntu-touch/stable/bq-aquaris.en --bootstrap --device="vegetahd"
[sudo] password for jlam: 
2016/09/29 08:58:37 Device is |vegetahd|
2016/09/29 08:58:37 Flashing version 15 from ubuntu-touch/stable/bq-aquaris.en channel and server https://system-image.ubuntu.com to device vegetahd
/home/jlam/.cache/ubuntuimages/ubuntu-touch/stable/bq-aquaris.en/vegetahd/version-15.tar.xz
/home/jlam/.cache/ubuntuimages/pool/custom-7ee762289981fe54f1cd374a17c6aabaf2720fb8d5b5a5b2e56e860032b3eb16.tar.xz
/home/jlam/.cache/ubuntuimages/gpg/image-signing.tar.xz
/home/jlam/.cache/ubuntuimages/pool/device-ff4a9b2ca3c4c0110b0d7fc05deb556b5634c213f450bd9da1b9ad2a8f09e215.tar.xz
2016/09/29 08:59:00 Can't boot recovery image
jlam@VEC-ubuntu-precision-m6300:~/Desktop/SP_Flash_Tool_exe_Linux_v5.1612.00.100$ 

UPDATE 3 30th September 2016

Trying to resolve the Can't boot recovery image error, I have been referring to this: How do I use ubuntu-device-flash with the BQ Aquaris E4.5 and Aquaris E5

I downloaded the file recovery-vegetahd.img and used the --recovery-image argument. I then got the error unknown flag recovery-image. I tried to update ubuntu-device-flash but there were no newer versions with Ubuntu 14.04, so I have updated by PC OS to Ubuntu 16.04. That has allowed me to update ubuntu-device-flash to a later version that does have the recovery-image flag. However, I am still at a dead-end.

jlam@VEC-ubuntu-precision-m6300:~$ sudo ubuntu-device-flash touch --channel=ubuntu-touch/stable/bq-aquaris.en --bootstrap --device=vegetahd --recovery-image /home/jlam/Downloads/recovery-vegetahd.img
2016/09/30 12:56:50 Device is |vegetahd|
2016/09/30 12:56:50 Flashing version 15 from ubuntu-touch/stable/bq-aquaris.en channel and server https://system-image.ubuntu.com to device vegetahd
Can't boot recovery image

UPDATE 4 10th October 2016

The SP Flash Tool does not work for me, ubuntu-device-flash does not work for me, so I am now trying fastboot. In my case, I often need sudo when a guide omits it. I have tried to flash Ubuntu by changing directory to where I have downloaded and decompressed Aquaris E5 Ubuntu Edition firmware and using the fastboot command like this:

sudo fastboot flash recovery recovery.img
sudo fastboot flash boot boot.img
sudo fastboot flash system system.img
sudo fastboot flash cache cache.img

However, the system.img does not flash. Furthermore, there are a number of image files that I do not know the correct command for:

EBR1
lk.bin
logo.bin
MBR
preloader_vegetahd.bin
secro.img

This link has been very helpful in giving the names of a few partitions used by the fastboot command. However, what are the others? This link also gives some good background information, but does not help with the correct partition for use with the fastboot flash (partition) file command. This link also gives some good examples of fastboot flash use, but does not cover all of my files.

The Android scatter text file also has information on each partition, but I do not know how to use this info with the fastboot command.

Obviously, these commands render the phone unbootable. However, downloading the Android firmware and flashing the recovery, boot, system and cache images from Android does return the phone to an Android condition, albeit a slightly unwell one.

Does anyone know what the correct partition names would be on a BQ Aquaris E5 4G (other than recovery, boot, system, cache and userdata)? Does anyone know how to resolve the system.img not flashing?

1

Googling this error, I have found:

Meaning: The flashing process took too long so SP flash tool encountered a timeout

Solution:

  • Try flashing one file at a time
  • Use the latest version of SP flash tool
  • Try using a different PC and USB cord.

However, using the flash tool is not recommended. See

https://lists.launchpad.net/ubuntu-phone/msg17235.html

and follow the links in there to find a better way of installing Ubuntu on your phone.

|improve this answer|||||
  • Good suggestion, I have followed the procedure in the links, but have come to a dead end. adb does not see my device at all, even after adb kill-server. fastboot does see the device, but I see no permissions instead of a device number, and fastboot reboot does not reboot the phone. – Jeffrey Lam Sep 22 '16 at 18:32
  • Does it still work with Android? If it does, what version of Android is it. – Tony Sep 22 '16 at 22:14
  • Yes. From settings, About phone: Android version 4.4.4, Kernel version 3.10.28, Build number 1.8.4_20150727-1246-8G. It might also be worth noting that there is no "OEM unlock" in the Developer options. – Jeffrey Lam Sep 23 '16 at 6:59
  • Well, if your phone is working OK, I suggest you follow the instructions here developer.ubuntu.com/en/phone/devices/… – Tony Sep 24 '16 at 22:47
  • That link looks the same as the one your launchpad link leads to. I have tried it and adb and fastboot still don't work. However, I have made progress on a different front. I upgraded Android to Lollipop (Android version is now 5.1.1). I noticed some changes: 1. OEM unlocking is now available in Developer options. 2. When I connect the powered on phone to my ubuntu PC with USB debugging on, the phone asked me to confirm, which it hadn't before. 3. adb now works from the ubuntu PC when the phone is connected. Not there yet, but it looks positive. So, I needed to upgrade to Lollipop. – Jeffrey Lam Sep 28 '16 at 13:54
0

My phone is a BQ Aquaris E5 4G, codename vegetalte. The images supplied by both BQ and in ubuntu-device-flash are for the BQ Aquaris E5 HD, codename vegetahd.

I have looked them both up and they have different specs. Most importantly they have different CPUs and different instruction sets, so it seems that there is no chance that the image for vegetahd will work for vegetalte.

So it is time to stop trying to flash these images. Thanks everyone for your help.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.