I have recently bought HP Pavilion 15 AU113TX laptop, which comes with Intel Core i5 7200U Kaby Lake processor, I have installed Ubuntu GNOME 16.04.1 on it, and it is unable to detect WiFi adapter.

  • Upon running lspci -nnk | grep -A2, I'm getting following information about adapter.

    028005:00.0 Network controller [0280]: Intel Corporation Device [8086:24fb] (rev 10)
            DeviceName: Intel Dual BandWireless-AC 3168 802.11 ac 1x1 WiFi + BT 4.0 Combo Adapter
            Subsystem: Intel Corporation Device [8086:2110]
  • But running rfkill list all, I see following output (WiFi missing there).

    0: hci0: Bluetooth
            Soft blocked: no
            Hard blocked: no
  • And here's the output for dmesg | grep iwl.

    [   13.570633] iwlwifi 0000:05:00.0: Unsupported splx structure
    [   13.635662] iwlwifi 0000:05:00.0: Direct firmware load for iwlwifi-3168-21.ucode failed with error -2
    [   13.650761] iwlwifi 0000:05:00.0: Direct firmware load for iwlwifi-3168-20.ucode failed with error -2
    [   13.650765] iwlwifi 0000:05:00.0: no suitable firmware found!
  • Output for ls -al /lib/firmware | grep 3168 Under both Stock Kernel 4.4.0-36 & Kernel 4.7.3.

    -rw-r--r--  1 root root   33168 Jul 13 01:03 hfi1_pcie.fw

Please note that this laptop is dual booted with Windows 10 Home, and WiFi is working fine there.

Now, I don't know if this adapter is supported by 4.4 kernel that Ubuntu 16.04 ships with, or it requires manual fix, as my laptop doesn't have hardware switch to turn on/off WiFi. Also, this being a combo adapter for both WiFi and Bluetooth, I can use Bluetooth just fine. Ethernet works too.

After searching around Intel® Dual Band Wireless-AC 3168 I found this page which suggests that support for this Wireless Adapter was added starting Kernel v4.6, and since 16.04 has Kernel 4.4, I tried two things.

1) Upgrade Kernel

I manually installed 4.7.3 from kernel.ubuntu.com, and booted into it but WiFi still remains undetected.

2) Loading firmware for this adapter version (3168).

I searched for .ucode files for this adapter and found it on OpenELEC's GitHub. So I copied iwlwifi-3168-21.ucode and iwlwifi-3168-22.ucode files to /lib/firmware/ and rebooted, but still no luck.


This seems to be a linux-firmware related bug, and I have filed the report on Launchpad. However, workaround given by Jeremy31 seems to fix WiFi under Kernel 4.7.4, but it breaks Bluetooth which was working fine with Stock Kernel 4.4.0-38. I'm still looking for a proper fix which doesn't cause any regressions (I'm fine with upgrading to newer stable Kernel release).

  • Please edit the question to add results for dmesg | grep iwl
    – Jeremy31
    Sep 22, 2016 at 9:21
  • @Jeremy31 I've added the output as you suggested.
    – Kushal
    Sep 22, 2016 at 13:51
  • May we also see: ls -al /lib/firmware | grep 3168
    – chili555
    Sep 22, 2016 at 17:37
  • @chili555 Added in the question!
    – Kushal
    Sep 23, 2016 at 3:48

3 Answers 3


You have an issue with firmware for the device with the 4.7 kernel

wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.161_all.deb
sudo dpkg -i linux-firmware_1.161_all.deb

Reboot into the 4.7 kernel and your wireless should function

  • Will try once I get home later today, is it something to do with current branch of 4.7 Kernel ? also, can I patch this firmware to 4.4 Kernel ? as if possible, I'd like to stick with stock Ubuntu Kernel. Thanks!
    – Kushal
    Sep 23, 2016 at 10:58
  • If you want it to work eventually with the Ubuntu kernel file a bug report at. bugs.launchpad.net/ubuntu I am not sure what happened that the firmware isn't present after you copied it but the result for chili555's command show that it isn't there
    – Jeremy31
    Sep 23, 2016 at 11:36
  • Man you're a savior, take a bow this fix worked!! And my bad, I deleted those files before running that command to add output here, as with those files in place, Wifi didn't work as well as running that command was showing bad file size errors for the firmware. Now that the problem is fixed, I'll be sure to file bug report, but if there any way I can continue to get security patches on Kernel 4.7 (may be by using PPA)?
    – Kushal
    Sep 23, 2016 at 13:10
  • One more thing I noticed is that while WiFi is working, Bluetooth now remains undetected.
    – Kushal
    Sep 23, 2016 at 16:40
  • 1
    That is likely another question to ask with the bluetooth tag
    – Jeremy31
    Sep 23, 2016 at 20:56

I have the exact same laptop and had this very issue and I'm so glad I found this thread. As @Jeremy31 suggested, it is a bug with the linux-firmware.

I did a sudo apt dist-upgrade and upgraded to the 4.8.* kernel and just everything works

Relevant info :

uname -a

Linux pwnbox 4.8.0-17-generic #19-Ubuntu SMP Sun Sep 25 05:29:05 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Bluetooth :

enter image description here

Wi-Fi :

enter image description here

  • 1
    I know everything works with Kernel 4.8, I tested Ubuntu 16.10 Beta 2 for the same. But problem is that 4.8 is still in RC, and I'm looking for fix that works with Kernel 4.4 (which is stock kernel for 16.04 LTS). Thanks anyway!
    – Kushal
    Sep 27, 2016 at 9:42
  • Ah, awesome. I should have read your launchpad ticket more carefully :) Sep 27, 2016 at 9:44
  • Just wanted to ask one thing, did you run dist-upgrade on Ubuntu 16.04? as I tried running the same but it doesn't show any packages for installation.
    – Kushal
    Sep 27, 2016 at 13:08
  • It's ubuntu 16.10 :) Sep 28, 2016 at 19:00
  • Oh, I felt so. Though 16.10 Beta 2 running Kernel 4.8 RC8 has great out of the box support for this hardware, can't wait to configure once 16.10 releases!
    – Kushal
    Sep 29, 2016 at 6:10

I have the same issue but on different laptop. This laptop is an Acer Extensa 2540. I did a clean install of Ubuntu 16.04.2 and later run this single command:

apt install linux-generic-hwe-16.04

You can find more information about HWE here https://wiki.ubuntu.com/Kernel/LTSEnablementStack

  • 1
    Worked for me as well on an MSI GL62M (adding the make so people googling for it find this answer) Sep 17, 2017 at 10:31
  • @GuntramBlohm Thanks a lot, I tried this for a MSI GP62MVR and, to my surprise, it worked perfectly. (the WiFi card wasn't detected with the default kernel of Ubuntu 16.04 LTS)
    – A.L
    Sep 23, 2017 at 0:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.