When I hibernated my computer and I fire him back up, my network connection is lost in about 50% of the cases. The network applet finds other networks, but it can't find the network I was connected to before the hibernate.

I have this most of the time with a wired connection but it also happens with a wireless connection.

I've tried re-plugging the cable (or switching off and on the wireless card), disabling the network via the network applet and re-enable it. The only thing that works is the following:

  • log out
  • log in back again
  • disable all networks
  • enable them again
  • possible duplicate of Suspend problems in 13.10 – guntbert Nov 18 '13 at 18:07
  • Although above mentioned question is itself closed as "bug" the answers will tell you about a workaround. – guntbert Nov 18 '13 at 18:08

Try restarting your network manager;

Open a terminal window and run the following command:

sudo service network-manager restart

In general keep this command somewhere. It's pretty useful.

| improve this answer | |
  • And this do? what this do? – Braiam Nov 14 '13 at 14:24
  • try typing it in a terminal when you're having this problem, it might fix it – Mina Michael Nov 14 '13 at 14:34

This is a bug that occurs on many systems (sorry I do not have the link to hand). I'm not sure there is a fix for it as yet, as previously it was solved (for me at least) but broken after some updates. Works for me on suspend right now though.

If it is with wireless only, there is probably not much you can do, but if it is with a wired network, your best is to report a bug against network-manager on launchpad.

You could also try switching to connman (I don't use this so cannot verify) as it might work better than networkmanager in your situation.

| improve this answer | |
  • Well, the frequency is falling back. I estimate it now only happens 10% or maybe less of the hibernates and not 50% anymore. I think I could live with that. – sanderd17 Oct 30 '10 at 13:01
  • ahh that's good ^^. If your question was answered remember to mark it as such. – RolandiXor Oct 31 '10 at 21:16
  • well, it's still not completely gone, but it's just more difficult to test. – sanderd17 Nov 3 '10 at 13:20

I had the same problem on Ubuntu 10.04 and used this solution:


Since installing Ubuntu 10.10 (fresh install) I haven't experienced this problem.

Hope that helps!

| improve this answer | |
  • in any case, it didn't do anything bad. I will try it for a few days, if it keeps working, I'll mark this as the correct answer. – sanderd17 Nov 3 '10 at 13:21
  • sorry, it didn't work, my computer just did the same thing. Thanks for searching anyway. – sanderd17 Nov 5 '10 at 17:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.