2

I am trying to build a 32 bit version of Wine in a Linux container. When I start the container, attach, and login, and enter the command sudo apt-get update I get the error sudo: main: unable to allocate memory. I tried setting the overcommit_memory to 1, but it still does not work. Does anyone know what is going on?

2

Are you following the WineHQ wiki to build Biarch 32 / 64 bit wine?

Try:

apt-get update

without the sudo

I was rejected trying to sign into the container and had to Attach to it using sudo.

My prompt was:

sudo@my32bitbox

It was not:

username@my32bitbox

After a couple of hours reading about main: unable to allocate memory and getting nowhere I realized some other diagnostic commands ran fine without sudo so I tried the update and the other 2 commands that follow it and they worked fine without sudo as well.

  • Thanks for answering, and yes I was trying to build Biarch wine. I found the same thing. Apparently, the Linux container already had root access. – Ahsan Jan 19 '17 at 19:48

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.