0

I am having difficulty getting Owncloud calendar sync to work on OTA 13, which should support it directly.

I have a known-good Owncloud installation on an Ubuntu server, which syncs with several clients already. My account on that server has two calendars, which show as "Default2" and "Social events" in the web UI of the server. The CalDAV links which Owncloud gives for the calendar are respectively https://mydomain/owncloud/remote.php/dav/calendars/myname/default2/ and https://mydomain/owncloud/remote.php/dav/calendars/myname/socialevents/

I have a BQ Aquaris 4.5 which I upgraded to OTA 13, then reset to default configuration. This gave me one calendar, "Personal", on the phone itself. I then added the Owncloud account, using a URL of the form https://mydomain/owncloud (substituting my domain name of course) and with the appropriate user name and password. The phone accepted this as correct. Still working in "Accounts", I enabled access to this account for the Calendar application.

At this point the Calendar now shows two calendars: the original "Personal" and a new "Birthdays & Anniversaries". The new calendar seems to be read-only and does not contain any events. The name does not correspond to the name of either calendar on the server. Synchronising the Calendar app flashes up a brief message

Synchronization
Sync done: (user account details)
(Calendar)

which seems to indicate success. I can't find any way to show the real server calendars, or to establish that the Calendar app knows that they exist.

Any advice?

  • Are you using a self-signed certificate for your server? – dobey Sep 20 '16 at 21:13
  • @dobey: No, but good question. It's a Startcom certificate. It works without warnings in the web browser, and I've used some online services to check the configuration, so it should be fine. However I did find a web site that mentioned listing the calendars using "syncevolution --print-databases backend=caldav username=myname syncURL=mydomain/owncloud/remote.php/dav". This did not work. It reported "[ERROR] transport problem: PROPFIND: Neon error code 1, no HTTP status: could not verify server certificate: Some constraint limits were reached". – scottwh2 Sep 21 '16 at 0:10
  • Given that the certificate works fine with the web browser, I'm puzzled by this. Also you will have noticed that the recommended incantation contains a username but not a password, which doesn't seem right. – scottwh2 Sep 21 '16 at 0:10
  • I don't know about syncevolution incantations, but given that error message it seems to not be validating the certificate. This is probably a bug in either syncevolution or the HTTP library it is using (which appears to be neon). – dobey Sep 21 '16 at 2:09
  • @dobey: I agree. Do you happen to know if the OS CalDAV support uses the same library? I know: "read the source" - but I don't know which bit of the source. Also do you know if there is a way to enable logging? – scottwh2 Sep 21 '16 at 8:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.