0
prashanth@DELL-PK:~$ sudo apt-get install nodejs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
nodejs is already the newest version (4.2.6~dfsg-1ubuntu4.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

prashanth@DELL-PK:~$ npm install
The program 'npm' is currently not installed. You can install it by typing:
sudo apt install npm
  • 3
    'npm' only ships with the upstream nodejs package or far newer versions of the nodejs package - the one in Ubuntu is also very very old and I suggest using the version from NodeJS's repositories instead (which will install npm as part of the nodejs package) – Thomas Ward Sep 20 '16 at 20:06

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.