2

I am using ubuntu 16.04 LTS.
gedit does not start when I type in the terminal:

gedit

I do get the following error:

(gedit:9955): GLib-GIO-ERROR **: Settings schema 'org.gnome.gedit.preferences.ui' does not contain a key named 'notebook-show-tabs-mode' Trace/breakpoint trap (core dumped)

I googled this but nothing fixed the problem (I tried to remove then install it...etc)

When I run:

apt-cache policy gedit

I do get:

gedit:
Installed: 3.18.3.is.really.3.10.4-0ubuntu13
Candidate: 3.18.3.is.really.3.10.4-0ubuntu13
Version table:
*** 3.18.3.is.really.3.10.4-0ubuntu13 500
    500 http://ppa.launchpad.net/mc3man/older/ubuntu xenial/main amd64 Packages
    100 /var/lib/dpkg/status
 3.18.3-0ubuntu4 500
    500 http://dz.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
  • Are you installing gedit from the archives (ie with apt and you haven't added any other repos with gedit)? When you run apt-cache policy gedit, what is the result? The only thing I see online says this happens with gedit 3.4.2, but xenial uses 3.18.3 (disbauxes.upc.es/uncategorized/…). – Larry Price Sep 20 '16 at 18:13
  • @Larry Price: I edited the question – Navaro Sep 20 '16 at 18:19
  • You installed an older version. See the removal instructions here and reinstall from the repos. – Jos Sep 20 '16 at 18:22
  • @Jos : Sorry I do not see any instructions there – Navaro Sep 20 '16 at 18:25
  • 1
    I will post these instructions as an answer. – Jos Sep 20 '16 at 18:33
6

For some reason, you installed gedit from an obscure ppa (called ppa:mc3man/older), instead of from the official repositories.

First, remove the references to the ppa. The easiest way to do that is to install a program called ppa-purge:

sudo apt install ppa-purge

then use it to remove the offending ppa:

sudo ppa-purge ppa:mc3man/older

Then the package sources need to be updated:

sudo apt update

and the official gedit can be installed:

sudo apt install --reinstall gedit

Done. The last two commands will now probably succeed, so I combined them into one line using the && directive. This means: do the first command, then if successful, do the second command.

sudo apt update && sudo apt install --reinstall gedit

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.