Just installed Kubuntu 16.04 again and for some reason the taskbar pop-up menus are unusable. When i click any icon (wifi, bluetooth, hidden icons etc.) the popup menu flashes up and disappears back down again. It happens with the system tray items, digital clock and even with application menu/launcher.

Everything is updated/upgraded.

Any ideas?

  • Try a different mouse, the mouse could be defect. – mook765 Sep 20 '16 at 20:28
  • hey thanks for your suggestion, a good one actually, only it happens with touchpad and other mice too. Think i'll just reinstall the damn thing, feck it – user494199 Sep 21 '16 at 7:53
  • Never had that issue with Kubuntu 16.04, runs pretty stable, so i thought maybe aged mouse, but doesn't seem to be the case.When reinstall, don't forget sudo apt update and sudo apt full-upgrade to come to 16.04.1.Some issues still left, System Setting-GUI crashes pretty often but works.... – mook765 Sep 21 '16 at 10:53

I had a similar problem, and it was because I set the Focus stealing prevention to High.

Since you can't bring up the options from the menu as normal (oops), using App Menu -> Settings -> Configure Desktop -> Window Management -> Window Behavior -> Select [Focus] tab

From a command line, type kcmshell4 kwinoptions

Choose the Focus tab (already selected for me), scroll down to Focus stealing prevention and choose something less aggressive. Medium worked for me.


Have you installed all of the updates and upgrades of your system? Try

sudo apt-get update && sudo apt-get upgrade

and then

sudo apt-get install aptitude

after install aptitude, upgrade your system

sudo aptitude dist-upgrade

Something on kde must be missing, and these commands might help.

  • I guess re-installing also helps – Anwar Sep 20 '16 at 17:25
  • I haven't tried to reinstall kde on kubuntu though, it seemed complicated at that time. These commands I've suggested usually fix most of my problems with kde. – araujoyuri Sep 20 '16 at 17:27
  • Hey there, thanks for your suggestions but the problem remains. Think this could be another wild ubuntu goose chase that results in failure after 354354258 hours of searching, so i think i'll just reinstall the thing and be done with it. Once again, thanks for the suggestions! – user494199 Sep 21 '16 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.