I'm having a problem with booting a live image off of a USB Hard Drive. I used Startup Disk Creator to make an Ubuntu 11.10 live image on a partition on my external so that I can use it on various computers. I set it up with ~4GB of persistent data

So far I've tried it on two computers. One, a Dell, will boot to my external but it loads the select boot device very slowly. It hangs on a screen with an underscore for up to 5 minutes until it allows me to select which drive I want to boot from. After that, it works great.

However, on my primary computer it doesn't work at all. It's an Acer from 2009 and it won't even recognize the drive. I don't see it anywhere in BIOS or the select boot disk list. The light on the external will come on at boot just fine so I know it's powering it at this time.

Both computers worked perfectly with my 4GB flash drive that I had partitioned half and half (1st half FAT32 and second Ubuntu 11.10 live)

  • Had the same problem! I replaced Ubuntu with Kubuntu and everything worked fine! Never knew why!
    – Hanynowsky
    Nov 25 '11 at 23:03
  • 1
    What external drive is it? Looks like an hardware problem not a software one. Nov 25 '11 at 23:04
  • It's a brand new Hitachi 120GB. eshop.macsales.com/item/Hitachi/0A57910
    – JeremyT
    Nov 25 '11 at 23:30
  • Encased in this: eshop.macsales.com/item/OWC/ES2.5BPU3S
    – JeremyT
    Nov 25 '11 at 23:31
  • @Mediterran, did you try any pre-11.10 Ubuntu versions? I've only tried 11.10 and installed with Windows+Universal USB Installer and Ubuntu Live on flash Startup Disk Creator.
    – JeremyT
    Nov 25 '11 at 23:34

The problem you are facing is related to hardware, you are using a 2.5 inch external HDD enclosure that has no power source except the power provided by the USB ports.

Most modern hard disks require a certain amount of power to start spinning that sometimes the USB port is not enough to supply, what is happening in 1 computer is that the spin up is taking a long time but the drive starts on the 2nd computer the drive is not spining up fast enough so the computer does not recognize the drive.

To avoid this most drives capable of booting will have an extra power supply that you can use with your disk. Yours, as far as I can see, does not.

  • Not what I wanted to hear :-/ Is there any way to fix this problem? I've seen split Y USB 2.0 cables out there, any idea if there are any 3.0 ones? If so, would this fix my problem?
    – JeremyT
    Nov 26 '11 at 0:30
  • I tested the same config (Booting from a USB HDD powered by the same USB plug) and it won't work. Using a USB key works fine. Tried with a USB HDD powered by AC adaptor and it works fine! That is likey to be the right answer!
    – Hanynowsky
    Nov 26 '11 at 0:34
  • @Mediterran81 that is what I am saying in my answer. Nov 26 '11 at 0:41
  • 1
    @JeremyT just buy any cheap ass enclosure with an external power source. Nov 26 '11 at 0:41
  • @Bruno Pereira, by "That's likely to be the right answer" I mean your answer :)
    – Hanynowsky
    Nov 26 '11 at 0:46

In my Dell XPS 15, i have two ports which are USB 3.0. Trying to boot Ubuntu 11.04 or 11.10 from any type of HDD or usb key won't go ahead.

Hopefully, I have a USB 2.0/e-sata combo in the same laptop. And Booting and/or installing 11.04 or 11.10 from through USB 2.0 port works fine, for Ubuntu and Kubuntu.

Booting through USB 2.0 a WEstern Digital 500 GB HDD, which is USB-powered (one cable for data and power) will fail.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.