1

I recently realized strange behaviors of Konsole. It always stays in foreground and remains the focus.

Examples:

  1. I start Konsole. Then, I start Dolphin (or any other application). Dolphin will start but the Window will be behind Konsole. I have to use the task manager to switch to the Dolphin window. I'd expect that Dolphin starts in the foreground.

  2. I start Konsole. The I press Alt+F2 to start KRunner. Krunner appears but immediately disappears. When I type a command, it's typed in Konsole. I'd expect that KRunner appears, stays and that I can run a command.

  3. I start Konsole. I click on the Application Launcher in the panel. The application launcher appears. If I now start to type, I would expect that it searches my applications, instead the command is typed in Konsole.

The problem seems to be unique to Konsole. Other applications (I tried Kate and Xterm) do not show this behavior. The behavior of Konsole seems to be new and I cannot remember what I did before it changed. I'm on Kubuntu 16.04.

The Keep above others option is not activated:

keep above others

Also the Application Launcher menu appears in front of Konsole. It would appear behind Konsole if the Keep above others option would be used.

What can I do to make Konsole behave as I expect?

5
  • What happens when you reset (just to narrow down the problem) your kde profile as described in the answer to this question: askubuntu.com/questions/109530/… can revert later) – Bruni Sep 21 '16 at 7:47
  • That fixes the problem. – Fabian Rost Sep 22 '16 at 13:27
  • That is nice. So you can now restore the backup, excluding everything related to konsole....I dont know exactly which files these are... – Bruni Sep 22 '16 at 14:02
  • I'm happy with the default profile, so I won't restore anything. If you write your comment as an answer, I'll accept it. – Fabian Rost Sep 26 '16 at 9:27
  • I adjusted my answer to include the solution you used. – Bruni Sep 26 '16 at 11:16
1

It sounds like you have enabled Keep Above others via right click --> more actions on the window border

The image below shows dolphin, but the option is available for all windows.

enter image description here

If this does not help, you could reset your kde profile by running:

mv ~/.kde4 ~/.kde4.old
1
  • The Keep above others option is not ticked. I updated the question accordingly. – Fabian Rost Sep 21 '16 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.