2

Installed the latest available icaclient deb (13.4) and tried to connect to server.

However, not able to connect.

Also tried with old versions of icaclients (13.1, 13.2 and 13.3), didn't help

Followed the doc:

https://help.ubuntu.com/community/CitrixICAClientHowTo

Anyone facing similar issue?

1

I am using version 13.4.0.10109380 without any problems on 16.04. I just installed the .deb version. Maybe you should enable connection logs on Receiver to troubleshoot the nature of the problem. See https://docs.citrix.com/en-us/receiver/linux/13-2/linux-about.html to find out how to do that.

7
  • Thanks for the suggestion.. Actually there is an update. For me, None of the icaclient versions are working in Ubuntu 16.04. Editing the question accordingly and adding the logs. Sep 20 '16 at 14:56
  • [2016-09-20 20:17:39.928] [T 4158a700] [CtxBeaconSvr.cpp:103] [-] CitrixAuthManagerSDK::AMResult CtxBeaconSvr::checkLocationForStore()(NETWORK_LOCATION_LAN) [2016-09-20 20:17:40.109] [T 4158a700] [CtxBeaconSvr.cpp:95] [+] CitrixAuthManagerSDK::AMResult CtxBeaconSvr::checkLocationForStore()(https://xxxxxxxxxxxx.com/citrix/roaming/accounts) [2016-09-20 20:17:40.109] [T 4158a700] [LinuxLocationManager.cpp:242] [-] location : https://xxxxxxxxxxxx.com/citrix/roaming/accountshas reachability : kNETWORK_LOCATION_LAN Sep 20 '16 at 15:02
  • The output is not very informative. Have you ever been able to connect to the server with any version of icaclient?
    – JhmL
    Sep 21 '16 at 8:09
  • No I was not able to connect using any versions in Ubuntu 16.04. Here is a more detailed log paste.ubuntu.com/23211408 \n However in Ubuntu 14.04 I was able to connecting using icaclient 13.1. Later versions threw the above mentioned error in Ubuntu 14.04 also Sep 21 '16 at 13:43
  • I'm sorry but I won't be able to help you. One more suggestion could be to uninstall icaclient completely and delete the /opt/Citrix/ICAClient if that was not done automatically. If you need help how to do that let me know. After that try to install the citrix receiver again.
    – JhmL
    Sep 21 '16 at 18:39
0

Hi I had previously managed to get Citrix Receiver 13.4 working in Kubuntu, Linux Mint and Debian using the Ubuntu "HowTo" doc you referred to. When I tried doing the same in Maui OS, it didn't work until I spotted the little arrow next to my username which gave me a drop down menu with "Activate" and "Logoff". Clicking "Activate" made Citrix work or me. Not sure if everyone will have such a drop down menu, but it might be worth checking. Regards Alan

0

I had a black/blank screen on second monitor with Ubuntu Gnome 16.10 and icaclient 13.4 after following the guide at https://help.ubuntu.com/community/CitrixICAClientHowTo

I tried to prevent Citrix from starting FULL SCREEN by opening a terminal (Ctrl+Alt+T), gedit ~/.ICAClient/All_Regions.ini and setting DesiredHRES=1366 and DesiredVRES=768 but that didn't work.

I found that setting TWIMode=False in the All_Regions.ini file solved my issue and even spanned the window across both screens.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.