4

NOTE: Don't rush to mark as duplicate - most of the similar questions consider very old Ubuntu versions and their answers are not applicable.

I have Lenovo T460s with the latest Ubuntu 16.04. I like my lid closed when it's docked / connected to external monitors. However the moment I close the lid, the external monitors are turned off as well.

What I did so far:

  • Set "Do nothing" in "When the lid is closed" line of Power settings
  • Verified that #HandleLidSwitchDocked=ignore exists in /etc/systemd/logind.conf (tried uncommenting and restarting - did not change anything)
  • Set my monitor LCD screen to OFF (when other monitors are connected)
  • In "Brightness&Lock", "Lock" is off, and "Turn screen off when inactive for" is set to 30 minutes
4
  • Did you upgrade from a previous version? – WinEunuuchs2Unix Sep 19 '16 at 22:05
  • Nope, fresh install, but copied over my old home directory (I used KDE previously) – Zaar Hai Sep 20 '16 at 7:14
  • Did you remove the # in the line #HandleLidSwitchDocked=ignore? Line start with # is a comment, no effect... – mook765 Sep 20 '16 at 18:51
  • HandleLidSwitchDocked=ignore is a default one. To be sure, I've additionally tried and uncommenting and rebooting, but it made no effect. – Zaar Hai Sep 20 '16 at 20:21
0

I don't know how to prevent them turning off, but doing something that would otherwise wake the system up (mouse movement, keypress etc.) will turn the external display back on.

Source: How do I prevent an external monitor from shutting off when closing my laptop lid?

0

The external monitor(s) turn off in Kernel 4.4.0-135. However in Kernel 4.13.0-36 the external monitor(s) simply reset and set Brightness to 1.00 and Gamma to 1.0:1.0:1.0.

Upgrading kernel would be the simplest way of solving the issue.

As the other answer mentioned simply moving the mouse will wake up the external monitors when using Kernel 4.4.0-135.

1
  • Can confirm same problem with kernel 4.4.0-185 today. – WinEunuuchs2Unix Jul 18 '20 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.