0

I have a computer that refuses to boot due to problems with NVIDIA drivers. I have tried everything I can think of to fix the drivers, but it always boots into low-graphics mode.

Therefore, I decided to try and run boot-repair from a USB drive (Ubuntu GNOME) to see if that might fix it, and after I select "Try without installing" it hangs on a black screen forever. If I select "check disk for defects" it reboots the computer. The strange part is, if I insert the same USB into my laptop, it works perfectly. Secure boot is off, booting from USB is enabled in BIOs, I've tried multiple ports, different flash drives, resetting the BIOs to defaults, dialing back my overclock... Nothing works.

Here are my system specs:

Asrock z77 Pro3

i5 3570k

32GB DDR3

PNY GTX 1060 6GB

256GB lite-on ssd

  • P.S. I think your problem with he Nvidia drivers can be fixed by adding nomodeset. – You'reAGitForNotUsingGit Sep 19 '16 at 18:16
  • Nope, that's already been done. Thanks for the suggestion though. – Daniel Sep 19 '16 at 18:36
  • Some just connect to motherboard Intel video to install system. Then install ppa and nVidia driver. You need ppa to get the vary newest nVidia driver. If you installed any other nVidia driver, you must purge first. askubuntu.com/questions/813676/… and: askubuntu.com/questions/760934/… – oldfred Sep 20 '16 at 4:10
  • @oldfred Thanks, I'll try uninstalling the card to boot the USB drive. I have already purged the old nvidia drivers, added the ppa, and installed the new drivers though. – Daniel Sep 20 '16 at 18:49
  • What version of Ubuntu? You probably need 16.04 to have it work with the very newest nVidia driver. – oldfred Sep 20 '16 at 20:21
0

Make sure your hardware (video card and ram) are seated correctly in your motherboard. If you can, create a second live USB, perhaps with a different version of Linux and see if you can boot from that.

|improve this answer|||||
  • My computer can boot Windows and run games perfectly, so I don't think that will work. Thanks for the thought though. – Daniel Sep 20 '16 at 18:44
0

and check if power cable is plugged. there are nouveau , "nvidia legacy" and nvidia drivers. You can blacklist each in /etc/modeprobe.d/whatsoever.conf by add blacklist nouveau or so.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.