21

On every operating system whenever I install LibreOffice it always seems to have an issue with properly spacing characters.

Here are some examples:
Ugly kerning

The first word is the exact same word in the same document and the same font, and yet, it looks different. (around letter e and n)

Second word has a strange gap between p and a

In the last word A and d almost overlap.

All of these are regular fonts. Nothing fancy. Any way to fix this?

P.S. Format>Character>Postition>Pair Kerning is already enabled.

5
  • I noticed this as well. Sep 19, 2016 at 17:13
  • I never noticed this until you asked this question. I have noticed that if you capitalize the first letter of the word changes the spacing as well. Upvoted so hopefully this question will get enough attention. +1
    – Terrance
    Sep 19, 2016 at 17:21
  • I don’t think you will get an answer because you’ve given very little detail here. What fonts? What version of LibreOffice? What Operating Systems? All of these might contribute, but I’d start with the fonts. For example, I don’t see anything like this with Liberation Sans in LO 5.3.0.3 in Ubuntu 16.04. Feb 28, 2017 at 3:47
  • 1
    Please note that this problem does not seem to persist when "publishing" documents either by exporting them to pdf or by printing them.
    – Bruni
    May 11, 2017 at 15:02
  • Same problem in Libreoffice 7.0
    – momo2047
    Sep 19, 2020 at 4:05

4 Answers 4

0

The weird letter spacing is due to bugs which have been resolved in LibreOffice 5.3.

At the time of writing, version 5.3.0 is available through a PPA, type the following into a terminal to ensure the latest version is installed:

sudo add-apt-repository ppa:libreoffice/ppa
sudo apt-get update
sudo apt-get install libreoffice
3
  • 3
    I have Libre Office 5.3.0.3 and the bug is still present. Try resizing the application window slowly and you will see the spacing around letters change as you resize it.
    – Rtsne42
    Mar 8, 2017 at 18:44
  • 1
    @Danchm01 try with pair kerning turned off. GPOS kerning is the new kerning algorithm, having pair-kerning enabled might be forcing use of the old algorithm.
    – Tyson
    Mar 8, 2017 at 22:32
  • 1
    Just upgraded from Writer 5.1 to 5.3. Kerning is worse.
    – mpen
    May 18, 2017 at 16:09
0

Maybe try to disable the "hardware acceleration" option under the Tools>Properties menu, then LibreOffice>View.

It helped me to solve some letter glitches like that in the past.

0

Your issue can probably be fixed by adding these settings to ~/.config/fontconfig/fonts.conf:

<match target="font">
 <edit name="rgba" mode="assign">
  <const>rgb</const>
 </edit>
</match>
<match target="font">
 <edit name="hinting" mode="assign">
  <bool>true</bool>
 </edit>
</match>
<match target="font">
 <edit name="hintstyle" mode="assign">
  <const>hintslight</const>
 </edit>
</match>
<match target="font">
 <edit name="antialias" mode="assign">
  <bool>true</bool>
 </edit>
</match>

This snippet does the following:

  • Enables subpixel antialiasing, which improves the looks of many fonts (this is the same system used by ClearType on Windows)
  • Sets font hinting to slight (this is usually the global default, but LibreOffice seems to not see it)
  • Turns on normal antialiasing (this works in conjunction with subpixel antialiasing)

Font hinting causes letters to be aligned with the pixel grid on your monitor, which can possibly cause kerning issues. By setting this to slight, inter-character space is preserved.

These issues usually only occur with Windows fonts or fonts designed to be metrically equivalent (such as the default LibreOffice font), for those are not designed with the concern of snapping to a pixel grid.

1
  • Does not works on Libreoffice 7.0
    – momo2047
    Sep 19, 2020 at 4:05
0

The kerning issues are very likely due to issues introduced in LibreOffice 5.3.

While LO 5.3 did introduce a feature targeted at complex glyph positioning (GPOS) and ligature replacement, etc., this new font rendering engine (or the tech is was attached to) was also somewhat broken/sloppy in regards to traditional kerning.

Because this question was asked shortly after the release of 5.3, the new engine seems the likely suspect here. (Although, as one commenter above notes, we don't know the LO version in question here.)

Thus, the old workaround was to fall back to LO 5.2.x. Very recently, however, LO 7.4 was released which has finally (6 years later) addressed some of these kerning issues. (Well, 7.4 looks good to me thus far, but I have no expectations it will stay fixed--or fixed for all--when it comes to free software.)

If, however, you are seeing kerning issues due to hardware, OS, or app settings (maybe you turned off kerning, font smoothing, or something else), no version of LO will likely help. These issues are typically related to things like anti-aliasing and sub-pixel positioning features such as ClearType. If things look better printed or zoomed in, it's probably not LO's fault.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.