I had VPN Unlimited working successfully on Ubuntu 14.04 having installed it via Ubuntu Software Center utility.

I have now installed 16.04 and downloaded VPN Unlimited, vpn-unlimited_2.8.0_amd64.deb from the VPN Unlimited website. I understand that Ubuntu 16.04 has replaced Ubuntu Software Center with (Gnome) Ubuntu Software utility.

  • If I try to install using Software Center the latter hangs.

  • If I try to install with GDebi I get:

    Error: Dependency is not satisfiable libjsoncpp0 (>=0.6.0~rc2)
  • Are you saying Software hangs and don't work? Or are you saying Software actually starts the install then hangs. Can you bring up Software center from the Ubuntu Button by launching it without trying to install an application? Sep 19 '16 at 14:21
  • I believe you appended something from the commandline. I was asking what happens when you run software center. Can you tell me what you get when you run gnome-software from the commandline? Sep 19 '16 at 14:34
  • No I didn't use the command line. I clicked the downloaded file and Software Center attempted to install it but failed. I right clicked the file and asked GDebi to install it with the result I gave in my initial message. Are you having a problem installing VPN Unlimited then?
    – Welshmike
    Sep 19 '16 at 14:45
  • I was trying to identify if there is a problem with Software center. Your message said you had installed it from Software center the before. Some people have problems with the new Software center working. The errors you're having trying to install the deb file has to do with libraries on the system. Since that isn't working I was trying to see what Software center isn't installing what it already has in it's cache. Sep 19 '16 at 15:07
  • Possible duplicate of askubuntu.com/questions/40779/… Sep 15 '17 at 4:25

VPN Unlimited support replied to my email to them within a few minutes supplying the following information for Ubuntu 16.04.

Here is version for 64 bit CPUs and Ubuntu versions:
This is for 32 bit Ubuntu 16.04 distro
You should download package for your distribution and install VPN Unlimited through Ubuntu package manager.
Or you can do this through root terminal application:
sudo apt-get update
sudo apt-get upgrade
sudo dpkg -i vpn-unlimited_3.2-i386.deb
sudo apt-get -f install

Ubuntu 16.04 does not have the older dependency that VPN Unlimited relies on. It is fairly easy to install the missing libjsoncpp0_0.6.0 dependency.

Essentially you will need to download the missing dependency from the below link


Then install it with:

sudo dpkg -i libjsoncpp0_0.6.0~rc2-3ubuntu1_amd64.deb

You should then be able to install VPN Unlimited without issue.

Additional reference info can be found in the guide below.


  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Feb 4 '17 at 6:48
  • Corrected as recommended.
    – The3DmaN
    Feb 4 '17 at 14:20
  • Thanks. Appreciate you making it a much better answer! @The3DmaN Feb 4 '17 at 18:09

This is slightly off topic still covering VPN Unlimited, but on Ubuntu 17.04 and on a headless server. It is offered as a working solution that might help others. Or at least offer some tips.

It's a simple setup of a VPN using VPN Unlimited on a headless Ubuntu Linux Server. Headless meaning no graphics capability, no keyboard or mouse. Ubuntu because of its popularity and extensive documentation. Maximum simplicity for a server tucked away in a cabinet only controlled through SSH from a MacOS Terminal. Although just about any SSH connection would do the job.

After several days of trial and error plus education in linux commands, this noob did get a simple system functioning. And, I thought my experience and this example might save others some time. There is a lot of OpenVPN info out there, but it is hard to cut through it to what pertains.

The Support Team at VPN Unlimited will respond to a request for configuration help with a policy answer: "We can provide manual PPTP/L2TP (username, password, and domain servers names) settings and .ovpn files, but you will need to configure your device using our settings by yourself at your own risk." And if okay with you, they will quickly provide those items very quickly.

Locate the VPN Unlimited Server you want to use and its .com filename in their response email. The key component is the 2 to 5 letter abbreviation that appears before .vpnunlimitedapp.com in the filename. Unzip the DECB1.zip file attachment. In there you will need a single .ovpn file that includes the same 2 to 5 letter abbreviation in its filename from the list of Servers.

VPN Unlimited uses OpenVPN Clients. Two sources of extensive information on OpenVPN with example commands and files may be helpful: https://community.openvpn.net/openvpn/wiki/Openvpn23ManPage https://openvpn.net/index.php/open-source/documentation/howto.html#examples

Remember to check for Client instructions. Not Server.

My approach is use the command line for almost immediate feedback to select and checkout functions, then put those commands into a script later to automate the process.

First, check to identify your current IP, which will respond with 4-digits.

dig +short myip.opendns.com @resolver1.opendns.com
responds for example like this->

Start a SSH session to install, configure and checkout the OpenVPN setup.

sudo apt install openvpn

Copy the appropriate server .ovpn file you found from the unzipped DECB1.zip. I used a Samba share to move the .ovpn file from email attachment to the Ubuntu Linux Server, but I leave it to you to use any technique to get it on there. The final step is get it into the OpenVPN directory.

cp <-your VPN Unlimited username with selected server abbreviation here->_DECB1.ovpn /etc/openvpn/

Enter and execute this command to configure and start OpenVPN.

sudo openvpn --client --config /etc/openvpn/<-your VPN Unlimited username with selected server abbreviation here->_DECB1.ovpn

You should see responses like this, ending with Initialization Sequence Completed on the last line.

sudoOpenVPN 2.4.0 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Jun 22 2017
library versions: OpenSSL 1.0.2g  1 Mar 2016, LZO 2.08
TCP/UDP: Preserving recently used remote address: [AF_INET]
UDP link local: (not bound)
UDP link remote: [AF_INET]
[openvpn2.vpnunlimitedapp.com] Peer Connection Initiated with [AF_INET]
Options error: option 'reneg-sec' cannot be used in this context ([PUSH-OPTIONS])
TUN/TAP device tun0 opened
do_ifconfig, tt->did_ifconfig_ipv6_setup=0
/sbin/ip link set dev tun0 up mtu 1500
/sbin/ip addr add dev tun0 local peer
Initialization Sequence Completed

Success (hopefully). No prompt appears in the terminal window. To disconnect press Control+C or close the window. Login again in a new terminal window using SSH. Check your new IP provided by the VPN Unlimited Server.

dig +short myip.opendns.com @resolver1.opendns.com
responds for example like this->

If your responses while trying to initialize look like this, it did not work.

OpenVPN 2.4.0 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Jun 22 2017
library versions: OpenSSL 1.0.2g  1 Mar 2016, LZO 2.08
Could not determine IPv4/IPv6 protocol. Using AF_INET
UDPv4 link local (bound): [AF_INET][undef]:1194
UDPv4 link remote: [AF_UNSPEC]

Check your syntax and files, then try again after entering these commands.

sudo service openvpn stop
service openvpn start

I also tried configurations using the username and password that were also provided in the VPN Unlimited email. They were put in a two-line file per the OpenVPN documentation and also tried using entry from a script. A typical command looked like this.

sudo openvpn --client --auth-user-pass /etc/openvpn/user-pass --config /etc/openvpn/<-your VPN Unlimited username with selected server abbreviation here->_DECB1.ovpn

The only thing that seemed to occur was the addition of two lines interspersed in a successful series of commands also ending in Initialization Sequence Completed.

WARNING: file '/etc/openvpn/user-pass' is group or others accessible
WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this

It didn't seem anything useful occurred or more security implemented with these extra steps. But of course it could be simply my lack of understanding. And for some reason, I could not get the --log option to work with these commands. Could be a noob shortcoming again.

So the simplest version did the job of VPN setup with the least complexity.

Along the same lines in keeping it simple, this is a way to stop OpenVPN and return to your original IP (no VPN). The sudo service openvpn stop command will not do it.

sudo killall openvpn

Next, I created 3 scripts like these in /usr/local/bin for access, to pretty-up what's displayed and generally be able to control things without having to deal with lengthy commands each time. Individual scripts are simple and easy to use instead of combining commands and then having to deal with process control to get them working. You will be able to initiate the script from anywhere since /usr/local/bin should already be in your $PATH.

Note the importance of adding an "&" at the end of the --config command after the filename. It's needed to put the openvpn process in the background and let you continue using the terminal in the same window. No Control+C or new window required.


    # add & at the end of the command to make new process
    # run in background and release the terminal
    echo "Press Return after conclusion of VPN setup"
    echo "ending with \"Initialization Sequence Completed\""
    echo "to then return control for a new command"
    read -p "Continuing in 4 Seconds...." -t 4
    sudo openvpn --client --config /etc/openvpn/<-your VPN Unlimited username with selected server abbreviation here->_DECB1.ovpn &


echo "Press Return after VPN process stops"
echo "ending with \"SIGTERM[hard,] received, process exiting\""
echo "to then return control for a new command"
read -p "Continuing in 4 Seconds...." -t 4
sudo killall openvpn


echo -n "Public IP address: "
dig +short myip.opendns.com @resolver1.opendns.com

For multiple VPN servers, different start scripts could be used each with a different file for <-your VPN Unlimited username with selected server abbreviation here->_DECB1.ovpn.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.