I've got two microphones. Both work well in Windows. However, in Ubuntu the first one (call it X) works fine, but the second one (call it Y) produces a lot of high-frequency noise. I know, the best thing to do is to buy a new microphone, but X is really old and the headset is broken, Y is almost new and works fine with Windows. Is there any way to apply a low-pass filter in ALSA? I've also noticed that the sound is a little bit softened...like telephone quality input.

My soundcard is: 00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02) i've got a toshiba notebook and I've just tried to edit the alsa config file adding this line: options snd-hda-intel model=auto

~ UPDATE ~ If I use arecord test.wav -f CD everything works fine.


I have just solved the problem: it is just a new kernel bug. You can solve it by using:

options snd-hda-intel model=<your_model_or-audo> position_fix=2

In /etc/modprobe.d/alsa-base.conf

  • Thank you very much!!! I spend two days in internet in searching about acer aspire one 532h internal microphone noise (with sound card Intel Corporation N10/ICH 7 Family High Definition Audio Controller aka Realtek 272). This fix my internal mic noises. Important: You need to adjust mic volume with the terminal alsamixer tool!!! – user54950 Apr 14 '12 at 18:05

I just had to open


and go to capture screen [F4] and set mic boost down, and mic record up.

enter image description here

  • I tried it as well, capture at 100 and both boosts at 0, but for me there was still white noise. – sashoalm Jan 3 '15 at 9:16
  • capture should be at 70. – Brannon Oct 16 '18 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.