I have a sandisk 8GB USB 2.0 pendrive. After making it into a linux live boot disk, it turned into a read only disk. I have done almost all type of solutions. I can access all the files in it and it reads without any problem. Same error when i checked using windows.

Can i correct it ?

2 Answers 2


I had almost the same issue, it turns out the Group permissions are read-only, and you cannot get them right again - UNLESS you change the UUID of your USB-stick.

See my question and answer here: USB stick read only

After changing the UUID and reformating the disk everything works normally again! Do try without reformating, and then change the group-permissions to Read-Write! Have not tried this, but it should work!!

So that didn't work, then we have to use the big Terminal hammer: [Ctrl][Alt]t brings forth the terminal so enter:

sudo dd if=/dev/zero of=/dev/sdx bs=512 count=16

This will erase the start of the USB-stick. this solution I got here: Refurbishing the USB-stick

Now you should be able to format it to fat32 - or something else without any further trouble!

  • Unfortunately this did not work for my stick. Nulled it entirely, new partition table, new partition, new UUID and with the next mount it was still read-only.
    – Brandlingo
    Dec 17, 2017 at 18:17

Given almost the same problem as the OP I tried Ken Mollerup's solution - twice - but it did not seem to do the trick.

However after killing nautilus (killall nautilus in the console) and then restarting it the issue was solved. It seems that Launchpad Bug 1021375 affects or affected this as well.

Sadly the question remains if I had to do both or if restarting nautilus was sufficient.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.