2

I am struggling with getting Ubuntu and Windows installed alongside each other.

  • I have two hard disks and Windows was installed some time ago on /dev/sdd where also the UEFI Partition lives.
  • Ubuntu is installed to /dev/sdc.

The Ubuntu Disk is partitioned using ext4 and swap whereas the Windows Disk looks like this: enter image description here

Now the problem: Once I connect the Linux SSD I can boot into Windows exactly once. I can select ubuntu in the UEFI Bios to boot and the grub will come up and allow me to boot into Ubuntu without problems. Changing the UEFI boot setting back to the Windows Bootloader will no longer work and I am unable to select the chainload option in my grub boot menu either.

The Windows bootloader will start apparently - but then I get the 0xc000000e Boot error and Windows won't start at all after that point.

Now the funny part: Once I unplug the ubuntu drive - windows will boot just fine again.

Honestly I am at a loss as to why this is happening. I intentionally wanted Ubuntu and Windows to be on two seperate drives and not touch the Windows bootloader so when I no longer need Ubuntu I can just unplug the Disk or format it and be fine with it. But for some reason the existance of the disk will screw up Windows.

I have disabled fast boot in Windows and disabled legacy boot in UEFI to make sure I am not trying to mix these two.

Any Ideas are welcome - I am honestly at a loss how to explain what the system is doing.

One thing I am still looking into is that the Ubuntu disk may be a MBR Disk and not GPT - I think I read somewhere that this can cause troubles with UEFI - still does not explain why I can boot Ubuntu and not Windows (so apparently the bootloader runs in either case).

1

BCD does not work well with hardware changes after install. When you get the error you should see a message like this:

Windows failed to start, a recent hardware or software change might be the cause. To fix the problem: 

1. Insert your windows installation disc and restart your computer. 

2. Choose your language setting, and then click "Next." 

3. Click "Repair your computer." 

If you do not have this disc, contact your system administratos or computer manufacturer for assistance. 

Status: 0xc000000e 

Info: the boot selection failed because a required device is inaccessible.

I can think in two solutions:

1) change the hardware order, this can be acomplished by changing SATA cable position on motherboard making linux last drive, i.e if you only have two drives, windows first, linux last. Or if your bios allows it change order inside bios (easy way).

2) If the first solution don't work (and probably won't) rebuild BCD, by making startup reparations with windows DVD, or try repairing with advanced startup F8.

EDIT (added more info):

Also won't hurt to check this info: https://msdn.microsoft.com/en-us/library/windows/hardware/dn640535(v=vs.85).aspx

and in particular this Q/A: https://msdn.microsoft.com/en-us/library/windows/hardware/dn640535(v=vs.85).aspx#gpt_faq_mixed_gpt_mbr

  • Thanks for the help. I tried all the F8 options - next up on my list to try was trying to repair it using a boot medium - but I am reluctant to try since I really don't want to end up reinstalling Windows :( I'll fiddle with changing around the SATA cables to see if that helps. – Tigraine Sep 19 '16 at 12:19
  • @Tigraine before making changes on windows (repairing), you should make a backup, so you avoid resintalling it. Anyway, let's see if changing order work first. – Ilovelinux Sep 19 '16 at 13:25
  • IT WORKED! Changing the order really did the trick. Apparently Windows is picky in that regard - ubuntu on the other hand handled changing the order of the SATA Ports without any hiccup. Now I can boot into both systems. Thank you very much! And yes - I would have done a dd backup of my windows disk - but since I didn't have space in the case for another disk I was trying to avoid having to juggle disks for backup :) – Tigraine Sep 19 '16 at 21:27
  • glad it worked, I been playing with disk order so much I think xDD – Ilovelinux Sep 19 '16 at 23:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.