3

I'm learning ubuntu from scratch as I do really like it, and in "hard" mode, only ssh access. I've managed to solve a lot of questions along the path but not this one.

When I was trying to install some package, I got unmet dependencies of that package (no matter which one, I've tried some and all of them show the same issue) and from webmin (package I downloaded, use sudo apt-get install webmin_1.810_all.deb but I did not install yet as it was showing unmet dependencies).

As I do get the webmin unmet dependencies with all packages I try this:

sudo apt-get install

and it also show the webmin unmet dependencies:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar «apt-get -f install» para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
 webmin : Depende: libnet-ssleay-perl pero no está instalado
          Depende: libauthen-pam-perl pero no está instalado
          Depende: libio-pty-perl pero no está instalado
          Depende: apt-show-versions pero no está instalado
E: Dependencias incumplidas. Pruebe de nuevo usando -f.

So the question is, what's going on here? why I'm getting this, if the package was not installed? How do I remove this?

EDIT: changed language into english, used the answer proposition of solution and I get this:

sudo apt-get -f install
[sudo] password for administrador:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  apt-show-versions libapt-pkg-perl libauthen-pam-perl libio-pty-perl
  libnet-ssleay-perl
The following NEW packages will be installed
  apt-show-versions libapt-pkg-perl libauthen-pam-perl libio-pty-perl
  libnet-ssleay-perl
0 to upgrade, 5 to newly install, 0 to remove and 3 not to upgrade.
1 not fully installed or removed.
Need to get 427 kB of archives.
After this operation, 1,734 kB of additional disk space will be used.
Do you want to continue? [Y/n]

Ok, I know this was caused by webmin unfinished install, so the question then is, how do I uninstall an unfinished installation of webmin, or how do I remove this dependencies if I don't want to install webmin (aka, using the "apt-get -f install")?

Thanks in advance.

PD: this server was restarted several times after the "try" of install webmin. Also, don't know if this is needed info but I'm using ubuntu server 14.04.5

  • I'd suggest to install the missing dependencies using Synaptic. I have checked for the dependencies you point at in your message and all of them are in there. – user123492 Sep 19 '16 at 10:58
  • @user123492 I don't have Synaptic as I'm in ubuntu server, no desktop or GUI, only ssh. Anyway I know how to fix dependencies and install webmin but that is not what I'm asking. – Ilovelinux Sep 19 '16 at 11:50
1
sudo dpkg --configure -a
sudo apt-get autoremove
sudo apt-get clean
sudo apt-get update

If it doesnt work

sudo apt-get autoremove <package name>

Or sudo apt purge

Try this

| improve this answer | |
  • This happened with me yesterday. I tried this many commands but unfortunately i did something wrong with ppa instructions and these above instructions also didn't solve my problem.i had to reinstall system :( ...if it works for u then its good – minigeek Sep 19 '16 at 16:57
  • This works. The first command show me exacly whitch is the problem, and sudo apt-get autoremove webmin uninstall the unfinished installation of webmin. Thanks. Also worths to mention that this command it's also usefull for this grep " install " /var/log/dpkg.log – Ilovelinux Sep 19 '16 at 18:12
  • Gud :) welcome to Ubuntu – minigeek Sep 19 '16 at 19:37
0

I had the same issue.

The "universe" repositories were commented out in my /etc/apt/sources.list

To fix:

Edit and remove the "#" in the front of these lines:

deb http://us.archive.ubuntu.com/ubuntu/ <distro> universe
deb-src http://us.archive.ubuntu.com/ubuntu/ <distro> universe
deb http://us.archive.ubuntu.com/ubuntu/ <distro>-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ <distro>-updates universe

Then:

apt update
apt full-upgrade -y
gdebi <package name> or apt install <package name>
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.