0

To install my LAMP stack on Ubuntu 16.04 I followed these instructions Here

With the exception of installing php 5.6 instead of 7.0 using

sudo add-apt-repository ppa:ondrej/php

phpmyadmin then threw an error saying mbstring was missing so I installed

sudo apt-get install php5.6-mbstring

now all I get is a white screen when trying to access phpmyadmin

After trying to access phpmyadmin I get this in the apache2 error log

[Sun Sep 18 21:20:51.306056 2016] [:error] [pid 21053] [client 127.0.0.1:34158] PHP Fatal error:  require_once(): Failed opening required '/usr/share/php/php-gettext/gettext.inc' (include_path='.:/usr/share/php') in /usr/share/phpmyadmin/libraries/select_lang.lib.php on line 477
  • I had previously followed those instructions on a separate installation with php7 and everything worked fine. – DMConklin Sep 19 '16 at 2:08
  • Have you checked your Apache error log? tail /var/logs/apache2/error_log – TRiG Sep 19 '16 at 2:10
1

After checking the Apache error log that TriG so kindly recommended I ended up installing

sudo apt-get install php-gettext

and it works fine now

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.