1

so I just installed a full Ubuntu build on a PC I got, and it seems to be working fine, but I can't install anything through the Ubuntu software center. I've tried removing and reinstalling using

sudo killall software-center
sudo killall -KILL software-center
cd ~/.config && sudo rm -r software-center
sudo apt-get update
sudo apt-get --purge --reinstall install software-center

found here

as well as

sudo apt-get -m --reinstall install python python-minimal dh-python
sudo apt-get -f install

Then

sudo apt-get remove software-center
sudo apt-get update
sudo apt-get install software-center

found here

But it's still having issues. It'll get about half way through the installation process, then it just hangs, and if I try to click anything inside the window it crashes. to be honest.. I'm just at a complete loss on how to even begin troubleshooting (previously I've only had a duel boot of ubuntu/windows that I very occasionally tried playing with..).

Don't know if this would be relevant, but my machine is running on Ubuntu 16.04 LTS

Specs are:

  • CPU Intel Core 2 QuadCPU Q9450 @ 2.66GHz × 4

  • GFX Gallium 0.4 on NV92

  • 32-bit OS

if there's anything else I can add to help, I'll be happy to do so.

0

1 Answer 1

0

It could be a dependency of software-center that is causing the issue. Try running these commands:

sudo apt purge software-center
sudo apt autoremove
sudo apt install software-center

This procedure will first purge software-center, then it will also remove all the dependencies of software-center, then reinstall the app.

Unfortunately, some of the dependencies of software-center are also dependencies of other apps, including some apps necessary for your system to work. Therefore will not be removed by sudo apt autoremove. So if this doesn't work, a re-install may help.

1
  • Okay, after doing that VLC was installed (which is odd, because it wasn't before hand, when the software center crashed, but it was after doing this..) I'm now trying to install steam (honestly, if I get those two, I'll be fine to figure this out at my leisure, but not having any games on here makes messing around with it a pain xP ) it went almost immediately (as in in about 5 minutes..) to the middle area, and then it hasn't moved for another 30-ish minutes.. is this an expected time frame? Is there a way to see how much, exactly, it's progressing so I'll know if it's a hung process or not?
    – Kramer42
    Sep 19, 2016 at 1:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .