I have a problem and to be honest am even a bit desperate, because I think that everything should be working. (and it worked couple hours ago just fine and then suddenly it just decided not to load)

Kernel: 3.0.13

Graphic: Ati Mobilitiy Radeon 4500

Drivers: latest fglrx from command line, then tried to install fglrx package from software center, then from proprietary packages installer and then switched to drivers right from ATI site (11.11) (don't remember the order, but I tried everyone possible I know)

Gnome shell installed without problem, after few hours using it it started to flicker and blink and doing some seriously not nice thing (as described in some previous question) So I tried to solve it by reinstalling graphic drivers, tried every one of those four versions (proprietary drivers, command line, software center, ati site) and after that I just can't log into gnome shell. Gnome shell shows as an option in Lightdm and when I try to log in it automatically changes into "safemode" gnome shell (god, I just forget how is it properly called) without animation and all those fancy stuff. Can anyone try to help me?

  • It's an issue with the AMD drivers and Gnome Shell, the open source radeon drivers work fine with the Shell. – Uri Herrera Nov 25 '11 at 18:22

As Uri implies, you have to uninstall fglrx and use the open source drivers to use gnome-shell.

For how-to uninstall fglrx and use the radeon drivers follow these steps:

 sudo /usr/share/ati/fglrx-uninstall.sh
 sudo apt-get remove --purge xorg-driver-fglrx fglrx*

then, reinstall the mesa drivers:

 sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri 

after restarting the x-server, you should now be able to get into gnome-shell.

  • Well this is weird... Last time I solved it a bit "harder" way - complete reainstall (I basically didn't have there so many packages and datas) and now I used open drivers... Few minutes ago I told myself "hey, I know it won't work, but I wanna see what exactly won't work etc etc" so i installed fglrx drivers ready for not working ("It's all fine, I have this answer") But after reinstalling mesa drivers, getting rid of fglrx and rebooting whole system I am still not able to get to gnome shell – Otaj Nov 27 '11 at 21:49
  • OK, finally I resolved it on my own. I reinstalled whole xorg package (have no idea why it didn't want to do anything, but doesn't matter) -> solved, gnome shell is ok – Otaj Nov 27 '11 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.