5

I am trying to perform backup on Ubuntu 16.04 LTS, i get the following error.

Tried googling the issue, could not find any working solution.enter image description here

How to rectify this issue ?

P.S. I have referred to this link also. Duplicity error pop-up on Ubuntu 16.04

  • 1
    Try running sudo apt-get update then sudo apt-get upgrade then sudo apt-get dist-upgrade then sudo apt-get autoremove then sudo apt-get install -f and finally sudo reboot. – You'reAGitForNotUsingGit Sep 18 '16 at 19:06
  • penta did you resolve this issue? – edlee Nov 29 '16 at 21:10
  • @edlee, nope...tried all tricks, none worked – penta Nov 30 '16 at 21:31
  • 1
    Does this answer your question? Duplicity error pop-up on Ubuntu 16.04 – Organic Marble Jan 11 '20 at 14:36
6

Try:

sudo apt-get remove duplicity
sudo apt-get install duplicity

Or run duplicity --version and install the missing packages.

  • Have the same issue as above. When I run --version or anything else, I get this message. duplicity --help Traceback (most recent call last): File "/usr/bin/duplicity", line 45, in <module> from lockfile import LockFile as FileLock ImportError: No module named lockfile – edlee Nov 29 '16 at 21:09
  • 1
    Run pip install lockfile ? – user4780495 Nov 30 '16 at 10:42
  • That got it working. THANKS!!! And, I know how it happened also -- I cleaned out the global Pip packages I could identify, Ha-ha! After upgrading to 16.04, I managed to leaked some packages out of my virtualenv. So it got spring-cleaned. – edlee Nov 30 '16 at 20:37
1

Maybe you need additional packages that are missing. I encountered the same issue once I reinstalled the Python.

$ pip install lockfile duplicity PyGObject

Make sure proper(which relates to Python that duplicity uses) pip is used if you use multiple versions of Python.

After you have installed the packages you might be able to ensure duplicity is running properly.

$ duplicity --version
duplicity 0.7.14
0

In my case, this error was caused because duplicity assumes that you are running python 2.X. I use python 3 - and had the link 'python' in /usr/bin pointing to a python 3 version. Removing that link and creating one that pointed to a python 2 solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.