0

For some reason my Terminator now seems to have 3 languages in use. Yes, three:

Terminator Settings

As you can see, there are Spanish, English and German all at the same time.

I think the English ones probably result from incomplete translations of Terminator, which I understand, but still there is the mix-up of Spanish and German.

Also, both Spanish and German can be seen when I run certain commands, such as the following, where the last sentence is in German:

Command Output

Systemwide my language is German. I used Spanish before but I've already changed that about 2 months ago. I have no idea what could be the cause of the issue.

  • Some settings from Spanish ,like currency settings probably have stayed. You can use LC_ALL=C nohup terminator & to launch new window with English only and close old one . Use it for now as workaround untill you find a fix. – Sergiy Kolodyazhnyy Sep 18 '16 at 10:56
  • Probably won't solve your problem but improves your system's language support: The first thing I'd do is to go to Language Support. If you launch it and your language packages are incomplete, it tells you (opens a separate window so you can't overlook it) and offers you to install them. – UTF-8 Sep 18 '16 at 11:09
  • @UTF-8 Yeah, I changed settings via Language Support, and all packages seem to be installed. – xji Sep 18 '16 at 11:14
  • @Serg I think I changed all relevant settings in Language Support to German. Maybe there are some other places for such settings as well? – xji Sep 18 '16 at 11:14
  • 1
    What's the value of your $LANGUAGE? This environmet variable might contain a colon-separated languages in the order of preference. I guess you'll see something like de:es there. – egmont Sep 18 '16 at 11:58
1

Multiple language can show up if you have your LANGUAGE variable set to a colon-separated list of languages, e.g. de:es. In this case apps using the gettext engine (that's almost all utilities that have translations) try to pick German, but then fall back to Spanish for each string that is missing its German translation. Should the Spanish translation also be missing for a certain string, the final fallback is always (American) English.

See e.g. https://www.gnu.org/software/gettext/manual/html_node/The-LANGUAGE-variable.html for details. In particular, as pointed out on that page: "you still need to have LANG (or LC_ALL) set to the primary language".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.