0

My camera is Jenoptik 4.1 Exclusive. When I search it with lsusb I see it as:

Bus 001 Device 002: ID 0c45:6340 Microdia Camera

With dmesg | tail I get:

[78729.405075] sd 9:0:0:0: [sdb] No Caching mode page found
[78729.405080] sd 9:0:0:0: [sdb] Assuming drive cache: write through
[78729.442988]  sdb: sdb2 
[78729.446699] sd 9:0:0:0: [sdb] Attached SCSI disk
[78730.101931] EXT4-fs (sdb6): mounting ext3 file system using the ext4 subsystem
[78730.195900] EXT4-fs (sdb6): warning: maximal mount count reached, running e2fsck is recommended
[78730.197228] EXT4-fs (sdb6): mounted filesystem with ordered data mode. Opts: (null)
[78742.651650] systemd[1]: snapd.refresh.timer: Adding 3h 57min 53.625951s random time.
[78790.352037] systemd[1]: snapd.refresh.timer: Adding 5h 26min 50.018317s random time.
[78926.123095] usb 2-3: USB disconnect, device number 7

But it doesn't mount and I don't see it with any program. I work on Ubuntu 16 / 64bit

Any idea?

I tried also

git clone http://repo.or.cz/r/microdia.git
cd microdia
make

But I got error:

make -C /lib/modules/4.4.0-36-generic/build SUBDIRS=/home/ucc/microdia modules
make[1]: Entering directory '/usr/src/linux-headers-4.4.0-36-generic'
  CC [M]  /home/ucc/microdia/sn9c20x-v4l2.o
/home/ucc/microdia/sn9c20x-v4l2.c: In function ‘v4l_sn9c20x_register_video_device’:
/home/ucc/microdia/sn9c20x-v4l2.c:1463:11: error: ‘struct video_device’ has no member named ‘parent’
  dev->vdev->parent = &dev->interface->dev;
           ^
/home/ucc/microdia/sn9c20x-v4l2.c:1465:11: error: ‘struct video_device’ has no member named ‘current_norm’
  dev->vdev->current_norm = 0;
           ^
/home/ucc/microdia/sn9c20x-v4l2.c:1472:12: error: ‘struct video_device’ has no member named ‘debug’
   dev->vdev->debug = V4L2_DEBUG_IOCTL_ARG;
            ^
/home/ucc/microdia/sn9c20x-v4l2.c:1472:22: error: ‘V4L2_DEBUG_IOCTL_ARG’ undeclared (first use in this function)
   dev->vdev->debug = V4L2_DEBUG_IOCTL_ARG;
                      ^
/home/ucc/microdia/sn9c20x-v4l2.c:1472:22: note: each undeclared identifier is reported only once for each function it appears in
/home/ucc/microdia/sn9c20x-v4l2.c: At top level:
/home/ucc/microdia/sn9c20x-v4l2.c:1555:2: error: unknown field ‘ioctl’ specified in initializer
  .ioctl = v4l_sn9c20x_ioctl,
  ^
/home/ucc/microdia/sn9c20x-v4l2.c:1555:11: warning: initialization from incompatible pointer type [-Wincompatible-pointer-types]
  .ioctl = v4l_sn9c20x_ioctl,
           ^
/home/ucc/microdia/sn9c20x-v4l2.c:1555:11: note: (near initialization for ‘v4l_sn9c20x_fops.open’)
scripts/Makefile.build:258: recipe for target '/home/ucc/microdia/sn9c20x-v4l2.o' failed
make[2]: *** [/home/ucc/microdia/sn9c20x-v4l2.o] Error 1
Makefile:1403: recipe for target '_module_/home/ucc/microdia' failed
make[1]: *** [_module_/home/ucc/microdia] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.4.0-36-generic'
Makefile:33: recipe for target 'driver' failed
make: *** [driver] Error 2
  • 1
    Does the program Cheese recognize your webcam? – Nick Weinberg Sep 18 '16 at 6:23
  • No I tried also GUVCView as well. – Rumen Sep 18 '16 at 17:47
  • I don't need to see it as camera, but as storage via the USB cable, to be able to extract the pictures from the card. In the past I did it, but now I get error when compile it. – Rumen Sep 18 '16 at 18:30

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.