0

been trying to boot ubuntu EFI mode installed on my internal HD with ubuntu 16.04 but nothing does it

If I boot without the USB stick I have a no bootable device error

I cannot figure how to add manually the entry in the grub bootloader using the "try ubuntu" boot.

Can please someone point me in the right direction where to find information on how to add a menuentry in the 40_custom file ? I tried various options on the internet but 2 days and no success :( What is the correct way of configuring Grub2 manually ?

I have an ACER aspire 11 if that is any use. I disabled secure boot already.

I booted from boot repair disk and here is my report: paste.ubuntu.com/23196933

Thank you in advance

  • I have tried to boot manually from the grub command line by entering: grub> set root=(hd1,gpt1) grub> linux /boot/vmlinuz-3.13.0-31-generic root=/dev/sda1 grub> initrd /boot/initrd.img-3.13.0-31-generic grub> boot – Dev0urCode Sep 18 '16 at 8:27
  • I booted from boot repair disk and here is my report: paste.ubuntu.com/23196933 – Dev0urCode Sep 18 '16 at 9:00
  • One more thing I noticed; when I install in a VM at some point during the install I am asked to update the grub booloader. when I install on my laptop I am not asked that so is it a bug in the installer ? – Dev0urCode Sep 18 '16 at 9:17
  • It looks like your USB installer flash drive is promoted to sda and you are installing to a media card mmcblk0. But in UEFI mode grub only installs to drive seen as sda, so it may install the version of grub to boot install in the installer's ESP - efi system partition. But external drives only boot from /EFI/Boot/bootx64.efi. Do you now have a /EFI/ubuntu folder in installer? – oldfred Sep 18 '16 at 17:12
  • Thank you so much for the help; feels like we are going in the right direction as my EFI folder is empty :/ the media card is my internal memory of the laptop: 32gb. I think that is what they use on cheap laptop like mine; no real hd – Dev0urCode Sep 18 '16 at 17:24
0

You may need to do some manual changes to your ESP (EFI-System-Partition) Start Lubuntu from your Installer-USB-stick, Try Lubuntu. Now we will mount the ESP and create some directories, copy the file grubx64.efi to the new directories and rename the copied file. First mount the ESP in terminal with

sudo mount -t vfat /dev/mmcblk0p1 /mnt

You may open your filemanager now and browse to /mnt.You should find the following directories and files:

/mnt/EFI
/mnt/EFI/ubuntu
/mnt/EFI/ubuntu/grubx64.efi

If you can't find the file grubx64.efi, you should run Boot-repair again with the Recommended-repair-option, but it looks like you have done that already and the file is in the correct location. If you found the file grubx64.efi in /mnt/EFI/ubuntu, go back to terminal and use the following commands:

sudo mkdir /mnt/EFI/Microsoft
sudo mkdir /mnt/EFI/Microsoft/Boot
sudo mkdir /mnt/EFI/BOOT

sudo cp /mnt/EFI/ubuntu/grubx64.efi /mnt/EFI/Microsoft/Boot
sudo mv /mnt/EFI/Microsoft/Boot/grubx64.efi /mnt/EFI/Microsoft/Boot/bootmgfw.efi

sudo cp /mnt/EFI/ubuntu/grubx64.efi /mnt/EFI/BOOT
sudo mv /mnt/EFI/BOOT/grubx64.efi /mnt/EFI/BOOT/bootx64.efi

Please be aware of case-sensitivity, if possible use copy and paste. Restart the machine and boot directly to EMMC: HBG4e 32G If you are still unable to boot Lubuntu from your internal drive now, I will be out of ideas.

Here you can find some background-information.

| improve this answer | |
  • Thank you very much for your answer but I can confirm I have installed ubuntu.. I booted on the usb stick and selected "install ubuntu" then went on from there... I also tried to install from the "try ubuntu" interface.. How is this possible ? I will try your method and get back to you – Dev0urCode Sep 18 '16 at 17:00
  • I don't know how it comes, I just see your drive has BIOS-MBR, partition is formatted with FAT, looks weird. I dont think Boot-repair can solve this. But we got the summary, so we can see what is fact. Good luck with next try... – mook765 Sep 18 '16 at 17:11
  • I have tried to do what you ask for this is not working. I am very confused because if I launch disk application I can clearly see that my internal memory is formatted to GPT and the 3 partitions are present as you mentioned above. the problem seem to be that the installer (even boot repair) seem to try working on the usb stick and not on the internal drive ? – Dev0urCode Sep 18 '16 at 17:14
  • The drive which has GPT-partition-table is /dev/mmcblk0, this is a 32GB flash-drive, not your 2TB hard-disk. – mook765 Sep 18 '16 at 17:26
  • I don't have any 2tb hard drive, the 32 gb is my internal memory on my cheap laptop where I installed ubuntu – Dev0urCode Sep 18 '16 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.