0

I want to install seafile client within my libertine container.

First I added the ppa with:

libertine-container-manager configure -a "ppa:seafile/seafile-client" -i myContainerID

Then I updatet with:

libertine-container-manager update -i myContainerID

Finally I tried to install seafile-gui and seafile-cli with:

libertine-container-manager install-package --id myContainerID --package seafile-gui libertine-container-manager install-package --id myContainerID --package seafile-cli

But I just get the error "E: Unable to locate package seafile-gui"

I tried it now to execute the app-apt-repository directly in the default container, which is my example-container:

libertine-container-manager exec -c "add-apt-repository ppa:seafile/seafile-client" Well, this command stops with the fallowing error:

mktemp: failed to create directory via template ‘/run/user/32011/confined/com.ubuntu.terminal/tmp.XXXXXXXXXX’: No such file or directory

  • For the mktemp error, it looks like you might be using the Terminal app, which is currently incompatible with libertine due to confinement. Use ssh or adb to use libertine. For the seafile package, I don't actually see seafile-gui listed as a package available in ppa:ubuntuhandbook1/corebird. Is that the right ppa? – Larry Price Sep 21 '16 at 19:03
  • Your are right. I used the Terminal App. I used now adb and the ppa is now added correctly. :-) Regarding the ppa address: It is a c&p mistake within my post. I corrected it right now in my post and in your answer. Nevertheless seafile-gui cannot be located. of course I used the update function before. – eDeviser Sep 21 '16 at 19:12
  • 1
    Oh - the main issue here is that seafile does not have a build for arm on vivid in that PPA (only amd64 and i386), so there are legitimately no installation candidates. If seafile has a deb available for arm, you can download it and install it directly with the install-package subcommand, but the odds are you may need to compile this yourself using a chroot or other mechanism if you want a vivid build. – Larry Price Sep 21 '16 at 20:37
1

It looks like you are using an outdated syntax for adding a repository with the configure subcommand. Try this instead:

$ libertine-container-manager configure --archive add \
          --archive-name ppa:seafile/seafile-client --id myContainerID

This is the correct syntax in python3-libertine>=1.3.1 and possibly earlier than that. When in doubt, you can always check libertine-container-manager configure --help for more information.

  • Hey Larry, thank you for thr correct syntax. Nevertheless my package cannot be located. And the mktemp-error is shown, too.:( – eDeviser Sep 21 '16 at 18:43
  • 1
    It looks like you are using the Ubuntu Terminal App, which cannot run libertine-container-manager operations. You need to use adb from another machine or other mechanism. – Larry Price Sep 21 '16 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.