1

I'm on Xubuntu 14.04. When I originally upgraded, I had the problem of both light locker and xscreensaver running simultaneously. After that was fixed, light locker has been running smoothly.

But, recently, I noticed my screen on after I was gone all day; it was on when I woke up the next morning; etc.

I tried changing settings, rebooting, looking for other screensaver-like processes, checking that the command args would update when I made changes in the settings UI, etc.

I can manually lock the screen with light-locker-command -l, but I don't remember to do that every time.

I wasn't able to find other askubuntu questions that address my situation.

Could there have been a problem with a recent update (I apply them appx. once/week)? Or, are there other things I should check?

  • I've since upgraded to Xubuntu 16.04 and have this same problem. I don't have xscreensaver installed (and it's not running). light-locker is running and I've tried updating, re-editing screensaver settings, and rebooting. – jrennie Feb 5 '17 at 16:54
1

Switch to xscreensaver.

$ sudo apt-get remove light-locker
$ pkill light-locker
$ sudo apt-get install xscreensaver

Edit the screensaver settings (click yes/okay if asked to start the daemon):

$ xscreensaver-demo

Open the XFCE Power Manager ("Power Manager" from the "Settings" menu) and de-select "Handle display power management" in the "Display" tab.

  • 1
    Blanks the screen, but doesn't put the monitor into power saver mode (no matter what combination of xscreensaver and XFCE power manager settings I try) – jrennie Feb 8 '17 at 20:56
  • I can force power save mode with xset dpms force suspend – jrennie Feb 8 '17 at 22:16
  • Ah, problem might have been that I didn't kill light-locker after removing it (I updated the solution). I have power options set in both xscreensaver and XFCE power manager and it is working consistently. I think it's xscreensaver that is putting the screen into power saving mode because I have short times in xscreensaver and longer ones in XFCE PM and the screen goes into power save mode quickly. – jrennie Feb 9 '17 at 19:11
  • This solution worked for me on Xubuntu 18.04 LTS, thanks @jrennie – AndyGaskell Sep 7 '18 at 13:42
0

I found this suggestion on a discussion group, but can't find the reference at the moment (thank you to whoever suggested it!)

  1. Log out
  2. Switch to a terminal (e.g. Ctrl-Alt-F1)
  3. Log in to the text terminal
  4. $ rm -rf ~/.cache/sessions/*
  5. $ exit
  6. Return to the graphical environment (Alt-F7)
  7. Log in as normal

Now, I'm getting screen saver & locking as configured via the xfce4 power manager.

  • Worked at first, but I came back the next morning with my screen completely on :-( – jrennie Feb 7 '17 at 3:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.